Bug 1659929 - Panic appears in registry pod log if delete bucket or region in image-registry
Summary: Panic appears in registry pod log if delete bucket or region in image-registry
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Corey Daley
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-17 08:43 UTC by Wenjing Zheng
Modified: 2019-06-04 10:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:21 UTC

Description Wenjing Zheng 2018-12-17 08:43:28 UTC
Description of problem:
If delete bucket or region in imageregistries image-registry, check the registry pod log, it will has panic info:
$ oc logs pods/image-registry-7f784b7947-794kj
time="2018-12-17T07:57:03.418234699Z" level=info msg="start registry" distribution_version=v2.6.0+unknown go.version=go1.10.3 openshift_version=v3.11.0+38aca24-64-dirty
time="2018-12-17T07:57:03.418725614Z" level=info msg="caching project quota objects with TTL 1m0s" go.version=go1.10.3
panic: No bucket parameter provided

goroutine 1 [running]:
github.com/openshift/image-registry/vendor/github.com/docker/distribution/registry/handlers.NewApp(0x179fae0, 0xc4200b4030, 0xc42051a700, 0xc420631400)
	/go/src/github.com/openshift/image-registry/vendor/github.com/docker/distribution/registry/handlers/app.go:127 +0x339c
github.com/openshift/image-registry/pkg/dockerregistry/server/supermiddleware.NewApp(0x179fae0, 0xc4200b4030, 0xc42051a700, 0x17a5460, 0xc42052ee10, 0x17a7340)
	/go/src/github.com/openshift/image-registry/pkg/dockerregistry/server/supermiddleware/app.go:96 +0x8a
github.com/openshift/image-registry/pkg/dockerregistry/server.NewApp(0x179fae0, 0xc4200b4030, 0x1787240, 0xc4200b83f0, 0xc42051a700, 0xc4204d85a0, 0x0, 0x0, 0x0, 0x0)
	/go/src/github.com/openshift/image-registry/pkg/dockerregistry/server/app.go:138 +0x2ae
github.com/openshift/image-registry/pkg/cmd/dockerregistry.NewServer(0x179fae0, 0xc4200b4030, 0xc42051a700, 0xc4204d85a0, 0x0, 0x0, 0x17bdf60)
	/go/src/github.com/openshift/image-registry/pkg/cmd/dockerregistry/dockerregistry.go:187 +0x19c
github.com/openshift/image-registry/pkg/cmd/dockerregistry.Execute(0x1783be0, 0xc4200b8518)
	/go/src/github.com/openshift/image-registry/pkg/cmd/dockerregistry/dockerregistry.go:162 +0x9c3
main.main()
	/go/src/github.com/openshift/image-registry/cmd/dockerregistry/main.go:56 +0x403


$ oc logs pods/image-registry-58b8dff8fb-s8rgz
time="2018-12-17T07:59:50.908625658Z" level=info msg="start registry" distribution_version=v2.6.0+unknown go.version=go1.10.3 openshift_version=v3.11.0+38aca24-64-dirty
time="2018-12-17T07:59:50.909426043Z" level=info msg="caching project quota objects with TTL 1m0s" go.version=go1.10.3
panic: No region parameter provided

goroutine 1 [running]:
github.com/openshift/image-registry/vendor/github.com/docker/distribution/registry/handlers.NewApp(0x179fae0, 0xc4200b6030, 0xc420545180, 0xc420082700)
	/go/src/github.com/openshift/image-registry/vendor/github.com/docker/distribution/registry/handlers/app.go:127 +0x339c
github.com/openshift/image-registry/pkg/dockerregistry/server/supermiddleware.NewApp(0x179fae0, 0xc4200b6030, 0xc420545180, 0x17a5460, 0xc420342750, 0x17a7340)
	/go/src/github.com/openshift/image-registry/pkg/dockerregistry/server/supermiddleware/app.go:96 +0x8a
github.com/openshift/image-registry/pkg/dockerregistry/server.NewApp(0x179fae0, 0xc4200b6030, 0x1787240, 0xc4200ba790, 0xc420545180, 0xc4204bc6e0, 0x0, 0x0, 0x0, 0x0)
	/go/src/github.com/openshift/image-registry/pkg/dockerregistry/server/app.go:138 +0x2ae
github.com/openshift/image-registry/pkg/cmd/dockerregistry.NewServer(0x179fae0, 0xc4200b6030, 0xc420545180, 0xc4204bc6e0, 0x0, 0x0, 0x17bdf60)
	/go/src/github.com/openshift/image-registry/pkg/cmd/dockerregistry/dockerregistry.go:187 +0x19c
github.com/openshift/image-registry/pkg/cmd/dockerregistry.Execute(0x1783be0, 0xc4200ba638)
	/go/src/github.com/openshift/image-registry/pkg/cmd/dockerregistry/dockerregistry.go:162 +0x9c3
main.main()
	/go/src/github.com/openshift/image-registry/cmd/dockerregistry/main.go:56 +0x403

Version-Release number of selected component (if applicable):
openshift-install v0.7.0-master-6-g8f02020b59147c933a08c5e248a8e2c69dad24ae

How reproducible:
always

Steps to Reproduce:
1.Delete bucket or region in imageregistries image-registry
2.Check registry pod log
3.

Actual results:
There will be panic info.

Expected results:
Should have graceful warning on bucket/region should be provided

Additional info:

Comment 1 Corey Daley 2019-01-03 04:52:42 UTC
https://github.com/openshift/cluster-image-registry-operator/pull/106 has merged, can you please check this again and see if it's still an issue?

Comment 2 Wenjing Zheng 2019-01-14 08:06:36 UTC
No such issue with image registry.svc.ci.openshift.org/openshift/origin-v4.0-2019-01-14-015843@sha256:78b3a86a7e4a3989618af8b3b604681d06b96de922b95474ed9ddec8aa03bf42.

Comment 6 errata-xmlrpc 2019-06-04 10:41:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.