Bug 1659971 - Setting slave volume read-only option by default results in failure
Summary: Setting slave volume read-only option by default results in failure
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sunny Kumar
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-17 09:57 UTC by Sunny Kumar
Modified: 2019-03-25 16:32 UTC (History)
1 user (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 16:32:47 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21874 0 None Merged geo-rep : fix slave volume read-only option 2018-12-17 17:22:31 UTC

Description Sunny Kumar 2018-12-17 09:57:04 UTC
Description of problem:

With this change https://review.gluster.org/#/c/glusterfs/+/21739/.
we are making Slave volume read-only by default during geo-rep setup.

But when separate ssh key is given for non root user setting slave volume
read-only option results in failure.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Additional info:

Solution: Check for extra param in case separate key is given for non-root user 
          and take action accordingly.

Comment 1 Worker Ant 2018-12-17 10:02:08 UTC
REVIEW: https://review.gluster.org/21874 (geo-rep : fix slave volume read-only option) posted (#1) for review on master by Sunny Kumar

Comment 2 Worker Ant 2018-12-17 17:22:31 UTC
REVIEW: https://review.gluster.org/21874 (geo-rep : fix slave volume read-only option) posted (#2) for review on master by Amar Tumballi

Comment 3 Shyamsundar 2019-03-25 16:32:47 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.