Bug 1659998 - cups fails to build if clang is installed
Summary: cups fails to build if clang is installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cups
Version: 7.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Zdenek Dohnal
QA Contact: Petr Sklenar
URL:
Whiteboard:
Depends On:
Blocks: 1662868 1672715
TreeView+ depends on / blocked
 
Reported: 2018-12-17 11:25 UTC by Kamil Dudka
Modified: 2019-08-06 12:40 UTC (History)
5 users (show)

Fixed In Version: cups-1.6.3-37.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1662868 1672715 (view as bug list)
Environment:
Last Closed: 2019-08-06 12:39:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2058 0 None None None 2019-08-06 12:40:00 UTC

Description Kamil Dudka 2018-12-17 11:25:33 UTC
Version-Release number of selected component (if applicable):
cups-1.6.3-36.el7


Steps to Reproduce:
1. yum install clang
2. brew download-build -a src cups-1.6.3-36.el7
3. yum-builddep ./cups-1.6.3-36.el7.src.rpm
4. rpmbuild --rebuild ./cups-1.6.3-36.el7.src.rpm


Actual results:
configure: WARNING: unrecognized options: --disable-dependency-tracking
checking for gawk... gawk
checking for x86_64-redhat-linux-gnu-clang... no
checking for x86_64-redhat-linux-gnu-cc... no
checking for x86_64-redhat-linux-gnu-gcc... no
checking for clang... clang
checking whether the C compiler works... no
configure: error: in `/root/rpmbuild/BUILD/cups-1.6.3':
configure: error: C compiler cannot create executables
See `config.log' for more details
error: Bad exit status from /var/tmp/rpm-tmp.Vv8OYA (%build)


Expected results:
Successful build.


Additional info:
This bug prevents the package from being automatically scanned by Covscan.  This fix for this bug is trivial:

--- a/cups.spec
+++ b/cups.spec
@@ -402,6 +402,8 @@ autoconf -I config-scripts

 %build
 export CFLAGS="$RPM_OPT_FLAGS -fstack-protector-all -DLDAP_DEPRECATED=1"
+export CC=gcc
+export CXX=g++
 # --enable-debug to avoid stripping binaries
 %configure --with-docdir=%{_datadir}/%{name}/www --enable-debug \
 %if %lspp

Comment 1 Zdenek Dohnal 2019-01-02 09:38:43 UTC
Hi Kamil,

thank you for reporting the issue and the patch! I'll clone the bug for RHEL 8 and investigate if the issue is there too. (plus I'll fix it in Fedora too, for future RHEL releases).

Comment 2 Zdenek Dohnal 2019-01-03 09:45:15 UTC
Kamil,

would you mind attaching repo files, which needs to be enabled to install clang? Default repos in rhel7 image do not have clang.

Comment 3 Kamil Dudka 2019-01-03 10:28:14 UTC
clang can be installed from EPEL-7, for example:

# yum install https://dl.fedoraproject.org/pub/epel/7/x86_64/Packages/e/epel-release-7-11.noarch.rpm
# yum install clang

Comment 22 errata-xmlrpc 2019-08-06 12:39:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2058


Note You need to log in before you can comment on or make changes to this bug.