Bug 1660055 - [downstream clone - 4.2.8] Incorrect behavior of IOThreads text box in edit VM dialog
Summary: [downstream clone - 4.2.8] Incorrect behavior of IOThreads text box in edit V...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.2.8
: ---
Assignee: Andrej Krejcir
QA Contact: meital avital
URL:
Whiteboard:
Depends On: 1643921
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-17 11:59 UTC by RHV Bug Bot
Modified: 2019-02-15 10:28 UTC (History)
8 users (show)

Fixed In Version: ovirt-engine-4.2.8.2
Doc Type: No Doc Update
Doc Text:
Clone Of: 1643921
Environment:
Last Closed: 2019-02-13 15:34:07 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1455944 None CLOSED integer field incorrectly allows text when entering text after first entering a valid integer 2019-02-11 14:51:11 UTC
Red Hat Product Errata RHBA-2019:0343 None None None 2019-02-13 15:34:09 UTC
oVirt gerrit 95227 master MERGED webadmin: IO threads text field has to be an integer 2018-12-17 11:59:52 UTC
oVirt gerrit 96359 ovirt-engine-4.2 MERGED webadmin: IO threads text field has to be an integer 2019-01-07 12:07:47 UTC

Description RHV Bug Bot 2018-12-17 11:59:29 UTC
+++ This bug is an upstream to downstream clone. The original bug is: +++
+++   bug 1643921 +++
======================================================================

Description of problem:
when editing VM -> resource allocation -> "IO Thread Enabled" text box, it is possible to enter an illegal value (any character and any number bigger than 127) value and click OK. after clicking OK, the dialog is closed but the new value is not saved.

Version-Release number of selected component (if applicable):
ovirt-engine-4.3.0-0.0.master.20181028124607.git19414bc.el7
vdsm-4.30.1-29.gitcbdbee9.el7.x86_64
libvirt-client-4.5.0-10.el7.x86_64
qemu-kvm-common-ev-2.10.0-21.el7_5.7.1.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Edit VM dialog -> resource allocation
2. Check the "IO Thread Enabled" checkbox
3. Enter an illegal value (for example: -fs@!j316839) in the textbox

Actual results:
The Edit VM dialog closed and didn't give any error that the value incorrect.

Expected results:
Should accept only positive integer value between 1-127
Action should be rejected if any other value is entered and dialog shouldn't be closed till legal value is entered.


Additional info:
Screen video attached.

(Originally by Meital Avital)

Comment 1 RHV Bug Bot 2018-12-17 11:59:31 UTC
Created attachment 1498550 [details]
screen video

(Originally by Meital Avital)

Comment 2 RHV Bug Bot 2018-12-17 11:59:32 UTC
validation done wrong?

(Originally by michal.skrivanek)

Comment 3 RHV Bug Bot 2018-12-17 11:59:34 UTC
I think the validation in the UI is ignored. It can be seen in the video, that the textbox turns red, because the value fails validation, but the update operation continues anyway.

The wrong value is not sent to backend, as the parameter have to be an integer.

(Originally by Andrej Krejcir)

Comment 6 RHV Bug Bot 2018-12-17 11:59:42 UTC
This is a duplicate of Bug 1455944 which was closed for capacity reasons.

We could write a workaround for this specific case, but it would not fix all the text boxes that expect integers.

(Originally by Andrej Krejcir)

Comment 7 RHV Bug Bot 2018-12-17 11:59:43 UTC
Verified on :
ovirt-engine-4.3.0-0.2.master.20181120211612.git51027b1.el7.noarch

(Originally by Meital Avital)

Comment 9 RHV Bug Bot 2019-01-09 14:23:05 UTC
WARN: Bug status (ON_QA) wasn't changed but the folowing should be fixed:

[Found non-acked flags: '{'rhevm-4.2.z': '?'}', ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status (ON_QA) wasn't changed but the folowing should be fixed:

[Found non-acked flags: '{'rhevm-4.2.z': '?'}', ]

For more info please contact: rhv-devops@redhat.com

Comment 10 Raz Tamir 2019-01-09 15:30:17 UTC
Martin,

Could you please take care of acking this bug?

Thanks

Comment 11 meital avital 2019-01-17 11:16:13 UTC
Verified on: 4.2.8.2-0.1.el7ev

Comment 15 errata-xmlrpc 2019-02-13 15:34:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0343


Note You need to log in before you can comment on or make changes to this bug.