Bug 166011 - kudzu assumes all 'sound' devices in device tree are snd-powermac
kudzu assumes all 'sound' devices in device tree are snd-powermac
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-15 15:09 EDT by David Woodhouse
Modified: 2014-03-16 22:55 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.1.120-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 03:18:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2005-08-15 15:09:20 EDT
Patch says it all...

--- kudzu-1.1.116.2/macio.c~	2005-04-25 23:09:53.000000000 +0100
+++ kudzu-1.1.116.2/macio.c	2005-08-15 11:13:43.000000000 +0100
@@ -153,7 +153,7 @@ struct device *macioProbe( enum deviceCl
 	// Supported
 	for (n = list->result->next; n != list->result; n = n->next)
 	{
-		if (n->path)
+		if (n->path && strstr(n->path, "mac-io"))
 			ret = 1;
 	}
Comment 1 Bill Nottingham 2005-08-19 03:18:33 EDT
Thanks, added to CVS, will be in 1.1.120-1.
Comment 2 David Woodhouse 2005-08-19 04:52:13 EDT
Thanks. Please could you do an initscripts rebuild some time to pull it in? The
kmodule utility will still be loading the wrong modules until that happens.

Actually, could initscripts use a dynamically linked libkudzu to avoid the need
for  such rebuilds?

Comment 3 Bill Nottingham 2005-08-19 17:23:57 EDT
Well, there is no dynamic libkudzu, so, not really. (It's not as practical to
have one, since it depends on other static-only libraries, such as libpci.)

Note You need to log in before you can comment on or make changes to this bug.