Bug 166014 - [RHEL3] Valid kernel address reported as 'Bad EIP value' by oops output
[RHEL3] Valid kernel address reported as 'Bad EIP value' by oops output
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Ernie Petrides
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-15 15:19 EDT by Issue Tracker
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-23 13:25:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2005-08-15 15:19:22 EDT
Escalated to Bugzilla from IssueTracker
Comment 3 Ernie Petrides 2005-08-15 16:10:42 EDT
Please do not file bug reports on unsupported kernels or for crashes that
can only be reproduced on tainted kernels.

The EIP value was printed just above the register dump (do_notify_parent+0x24b).

The place where "Code: Bad EIP value." was printed would normally display 20
bytes of kernel code space at and after the EIP value, but this doesn't work
on hugemem kernels.

There is nothing wrong with rw_vm().
Comment 6 Ernie Petrides 2005-08-23 13:25:46 EDT
To resummarize, when hugemem kernels crash, in place of the display of 20
bytes of code starting at the EIP value, the message "Code: Bad EIP value." 
is printed.  This is a shortcoming of the hugemem kernel, but it does not
affect the normal running of that kernel.

Since the code bytes are not useful, I see no reason to attempt to fix
this.  So I'm reclosing this bug as WONTFIX.
Comment 7 Dave Anderson 2005-08-23 13:47:59 EDT
I have to concur here.  Granted it's a bogus printf, but for all practical
purposes, who cares?  I have always wondered why that code byte list was ever
shown anyway; the *only* time I've ever used it was to remove it entirely
in a test patch to avoid wasting precious console screen space!  Even if
somehow the text section got corrupted, quite frankly I probably wouldn't
even notice as a result of those code bytes.  But probably more to the point is
that the last thing we want to do is muck with the general purpose rw_vm(),
and its callers -- to add another argument solely for the purpose of satisfying
this only-done-at-crash-time consumer.

Note You need to log in before you can comment on or make changes to this bug.