Bug 1660140 - User input not added to script header
Summary: User input not added to script header
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Reporting
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Lukáš Hellebrandt
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-17 15:37 UTC by Lukáš Hellebrandt
Modified: 2018-12-19 10:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-19 10:10:05 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Lukáš Hellebrandt 2018-12-17 15:37:29 UTC
Description of problem:
After adding a user input, header of script is not changed in the script edit textarea (or in "hammer report-template dump ..."), however, when exporting it, the new input is included there.

I would accept having to include it in the script manually in both cases but this behavior is inconsistent and doesn't seem right to me.

This bug is also true for reporting templates.

Version-Release number of selected component (if applicable):
Tested on Sat 6.5 snap 7

How reproducible:
Deterministic

Steps to Reproduce through WebUI:
1. Clone some report template
2. Edit the cloned report template, in the Inputs tab, add some input
3. After submitting, open in for editing again

Actual results:
The script doesn't contain the new input declared in its header

Expected results:
I think the script contents should be the same in the textarea and in the export

Comment 3 Marek Hulan 2018-12-19 10:10:05 UTC
Lukáš I'm not sure whether you've seen my reply but I believe this is not a bug. The "script header" you talk about is a comment. We store metadata into it that are useful on importing the template. There's a PR pending already to actually strip it from the template content so user will not see that at all. On export you can choose one of three modes (foreman_templates plugin) that would either generate such comment for you from scratch, remove it entirely or keep it as it is. The export functionality in core always generate new metadata, so it can be reimported back (or to different Satellite instance). This is not related to report templates, this is a behavior that we have for all templates for a while.

I'm closing this as NOTABUG for now.


Note You need to log in before you can comment on or make changes to this bug.