Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1660163 - Dashboard Menu widgets Role access won't save
Summary: Dashboard Menu widgets Role access won't save
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: GA
: 5.11.0
Assignee: Harpreet Kataria
QA Contact: Jaroslav Henner
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-17 16:24 UTC by Jaroslav Henner
Modified: 2020-08-28 04:52 UTC (History)
7 users (show)

Fixed In Version: 5.11.0.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-12 13:34:53 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:4199 0 None None None 2019-12-12 13:35:08 UTC

Description Jaroslav Henner 2018-12-17 16:24:57 UTC
Description of problem:
When creating new Dashboard Widget, there is Role Access -> Show button whith options "<To All users>", "<By Role>", "<By group>". When selected something else than <To All users>, there are more options, for example "Groups" which one can select. These options seem to not be saved when the Save button is clicked.

Version-Release number of selected component (if applicable):
Version 5.10.0.29.20181211195209_fd990a9


How reproducible:
2/2

Steps to Reproduce:
1. Add new Dashboard Widget
2. Apart other things, select some Groups when "<By Group>" is selected or select some User Roles when "<By Role>" is selected
3. Save

Actual results:
No roles or groups visible on the landing page
No roles selected after clicking on the Edit button

Expected results:
roles and groups preserved

Additional info:

Comment 3 Harpreet Kataria 2019-01-02 23:05:17 UTC
https://github.com/ManageIQ/manageiq-ui-classic/pull/5119

Comment 4 Jaroslav Henner 2019-07-02 17:10:15 UTC
Roles and groups seems to be saved with the Save button in 
Version 5.11.0.11.20190625161125_392c61e

Comment 6 errata-xmlrpc 2019-12-12 13:34:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:4199


Note You need to log in before you can comment on or make changes to this bug.