Bug 1660171 - update git package on RHEL-7.7
Summary: update git package on RHEL-7.7
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: git
Version: 7.7
Hardware: noarch
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Marcel Plch
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-17 17:07 UTC by Bruno Meneguele
Modified: 2019-01-07 22:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-07 22:46:54 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Bruno Meneguele 2018-12-17 17:07:52 UTC
Description of problem:
There are plans to use git-subtree in RHEL-7 kernel source tree and although
it's already supported on the current git version for RHEL-7 a feature that was
enabled in version 1.9.0 (negative pathspec ':!<path>') will be required. Its
usage was already proposed and posted for RHEL-8 and there the developers are
requiring at least git 2.13 in order to perform the desired task due to some
improvements on negative pathspec.

Because of that I would like to require an update to git 2.13 on RHEL-7 as
well, thus we can maintain the same code base as RHEL-8 for the desired
feature. In case it's not possible due to some dependency issue an update to at
least 1.9.0 would be enough.

Version-Release number of selected component (if applicable):
git version 1.8.3.1

How reproducible:
one of the commands that will be performed is:
$ git format-patch --no-renames -k --stdout ${lasttag}.. -- ':!redhat' | <awk-script>

which is used to generate kernel srpm changelog.

Actual results:
fatal: Unimplemented pathspec magic '!' in ':!/redhat'

Expected results:
no output

Additional info:
Please, focus on updating to 2.13. Just in case it's not
possible, update to 1.9.0 or newer.

Comment 3 Bruno Meneguele 2018-12-18 17:19:43 UTC
(In reply to Pavel Cahyna from comment #2)
> Hello, can you use rh-git218 from RHSCL?
> https://access.redhat.com/errata/RHEA-2018:3554
> https://access.redhat.com/documentation/en-us/red_hat_software_collections/3/
> html/3.2_release_notes/chap-rhscl#sect-RHSCL-Changes-git

Well, for myself it would be enough, but the change will require every kernel developer within RedHat to also use rhscl git package.
I'm not sure if require them all to take this step would be better than a base tools update. What do you think?

Comment 4 Pavel Cahyna 2018-12-20 13:52:21 UTC
What is the problem with using the rhscl git package, is it the need of doing "scl enable ..." before using git?

Comment 5 Bruno Meneguele 2018-12-20 17:07:42 UTC
(In reply to Pavel Cahyna from comment #4)
> What is the problem with using the rhscl git package, is it the need of
> doing "scl enable ..." before using git?

Actually that's not a problem. TBH I never really used scl in my daily work, hence I'm not sure what are the requirements to require an update on base tools when newer versions are present on scl.
Maybe with more people requiring such new version would be a good idea to update (at least to 1.9.0)? If that's not feasible or not recommended that's ok by me.

Comment 6 Pavel Cahyna 2019-01-02 09:50:39 UTC
The conclusion so far is that we should not update the package and let the users who need a newer version use SCL, that's why we provide it.


Note You need to log in before you can comment on or make changes to this bug.