Bug 1660197 - eBPF tools 'runqslower' and 'solisten' need man pages
Summary: eBPF tools 'runqslower' and 'solisten' need man pages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: bcc
Version: 8.0
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Jerome Marchand
QA Contact: Jean-Tsung Hsiao
URL:
Whiteboard:
: 1683720 (view as bug list)
Depends On: 1680631
Blocks: 1755139 1710948
TreeView+ depends on / blocked
 
Reported: 2018-12-17 18:46 UTC by John Pittman
Modified: 2021-08-30 12:31 UTC (History)
10 users (show)

Fixed In Version: bcc-0.11.0-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 15:37:08 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHELPLAN-25506 0 None None None 2021-08-30 12:01:29 UTC
Red Hat Knowledge Base (Solution) 3759511 0 Troubleshoot None Where are the man pages for eBPF tools 'runqslower' and 'solisten'? 2019-02-28 15:42:59 UTC
Red Hat Product Errata RHBA-2020:1594 0 None None None 2020-04-28 15:37:24 UTC

Description John Pittman 2018-12-17 18:46:54 UTC
Description of problem:

The eBPF tools 'runqslower' and 'solisten' need man pages.  All other tools in /usr/share/bcc/ have a man page.

Version-Release number of selected component (if applicable):

bcc-0.7.0-3.el8
bcc-tools-0.7.0-3.el8

Steps to Reproduce:

Install bcc & bcc-tools
# man runqslower
# man solisten

Actual results:

man pages do not exist

Expected results:

man page with detailed tool description/usage should be available

Comment 2 Jerome Marchand 2019-08-08 14:26:46 UTC
*** Bug 1683720 has been marked as a duplicate of this bug. ***

Comment 4 Jean-Tsung Hsiao 2019-12-04 02:58:22 UTC
Missing man page for runqslower:

[root@netqe24 ~]# rpm -qa | grep bcc
bcc-0.11.0-1.el8.x86_64
bcc-tools-0.11.0-1.el8.x86_64
python3-bcc-0.11.0-1.el8.x86_64
[root@netqe24 ~]# man runqslower
No manual entry for runqslower
[root@netqe24 ~]# uname -r
4.18.0-159.el8.x86_64
[root@netqe24 ~]#

Comment 5 Jerome Marchand 2019-12-04 14:07:53 UTC
(In reply to Jean-Tsung Hsiao from comment #4)
> Missing man page for runqslower:
> 
> [root@netqe24 ~]# rpm -qa | grep bcc
> bcc-0.11.0-1.el8.x86_64
> bcc-tools-0.11.0-1.el8.x86_64
> python3-bcc-0.11.0-1.el8.x86_64
> [root@netqe24 ~]# man runqslower
> No manual entry for runqslower
> [root@netqe24 ~]# uname -r
> 4.18.0-159.el8.x86_64
> [root@netqe24 ~]#

The man pages of bcc tools are all prefixed by "bcc-" to avoid conflicts. It seems than mandb db allows to find some tool without that prefix, but not runqslower. I'm not sure how mandb works, I wonder if that's related to the fact that runqslower is called runqlat in the NAME section. Looks like runqslower man page has been copy-paste from the runqlat one and not entirely edited afterwards:

$ man bcc-runqslower
runqslower(8)                                                              System Manager's Manual                                                             runqslower(8)

NAME
       runqlat - Trace long process scheduling delays.

SYNOPSIS
       runqslower [-p PID] [min_us]

Anyway, that's an other issue and I'll open a new bz for that.

Comment 6 Jean-Tsung Hsiao 2020-02-12 16:31:16 UTC
Can't pass "man runqslower":

[root@netqe30 bpf]# man runqslower
No manual entry for runqslower

Comment 7 Jean-Tsung Hsiao 2020-02-12 16:32:54 UTC
[root@netqe30 bpf]# rpm -qa | grep bcc
bcc-tools-0.11.0-2.el8.x86_64
bcc-0.11.0-2.el8.x86_64
python3-bcc-0.11.0-2.el8.x86_64
[root@netqe30 bpf]#

Comment 8 Jerome Marchand 2020-02-13 13:46:47 UTC
(In reply to Jean-Tsung Hsiao from comment #6)
> Can't pass "man runqslower":
> 
> [root@netqe30 bpf]# man runqslower
> No manual entry for runqslower

See my previous comment.

(In reply to Jerome Marchand from comment #5)
> The man pages of bcc tools are all prefixed by "bcc-" to avoid conflicts. It
> seems than mandb db allows to find some tool without that prefix, but not
> runqslower. I'm not sure how mandb works, I wonder if that's related to the
> fact that runqslower is called runqlat in the NAME section. Looks like
> runqslower man page has been copy-paste from the runqlat one and not
> entirely edited afterwards:
> 
> $ man bcc-runqslower
> runqslower(8)                                                             
> System Manager's Manual                                                     
> runqslower(8)
> 
> NAME
>        runqlat - Trace long process scheduling delays.
> 
> SYNOPSIS
>        runqslower [-p PID] [min_us]
> 
> Anyway, that's an other issue and I'll open a new bz for that.

Comment 9 Jean-Tsung Hsiao 2020-02-13 16:05:21 UTC
The fix has been verified:

[root@netqe10 ~]# man bcc-runqslower

runqslower(8)                  System Manager's Manual                  runqslower(8)

NAME
       runqlat - Trace long process scheduling delays.

SYNOPSIS
       runqslower [-p PID] [min_us]

DESCRIPTION

Comment 11 errata-xmlrpc 2020-04-28 15:37:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1594


Note You need to log in before you can comment on or make changes to this bug.