Bug 1660234 - nothing provides libnftnl.so.7()(64bit) needed by iptables-1.8.2-3.el8.x86_64
Summary: nothing provides libnftnl.so.7()(64bit) needed by iptables-1.8.2-3.el8.x86_64
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: iptables
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 8.0
Assignee: Phil Sutter
QA Contact: Tomas Dolezal
URL:
Whiteboard:
: 1660464 (view as bug list)
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs 1515824 1637323
TreeView+ depends on / blocked
 
Reported: 2018-12-17 22:18 UTC by Richard W.M. Jones
Modified: 2019-06-14 01:42 UTC (History)
9 users (show)

Fixed In Version: iptables-1.8.2-5.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-14 01:42:55 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Richard W.M. Jones 2018-12-17 22:18:26 UTC
Description of problem:

libvirt is uninstallable on RHEL 8 because iptables has a broken dep:

DEBUG util.py:439:   Problem: package libvirt-daemon-kvm-4.10.0-1.module+el8+2317+367e35b5.x86_64 requires libvirt-daemon-driver-network = 4.10.0-1.module+el8+2317+367e35b5, but none of the providers can be installed
DEBUG util.py:439:    - package libvirt-daemon-driver-network-4.10.0-1.module+el8+2317+367e35b5.x86_64 requires iptables, but none of the providers can be installed
DEBUG util.py:439:    - conflicting requests
DEBUG util.py:439:    - nothing provides libnftnl.so.7()(64bit) needed by iptables-1.8.2-3.el8.x86_64

Version-Release number of selected component (if applicable):

iptables-1.8.2-3.el8.x86_64

How reproducible:

100%

Steps to Reproduce:
1. See above.

Comment 1 Jiri Denemark 2018-12-18 09:02:01 UTC
This was broken by libnftnl-1.1.1-2.el8 which changed the libnftnl.so version
from 7 to 11. As a result of that, iptables cannot be installed anymore and
the buildroot for libvirt is broken.

So either iptables should be rebuilt or (preferably) the ABI breakage done in
libnftnl-1.1.1-2.el8 should be reverted.

Comment 3 Jiri Denemark 2018-12-18 09:14:30 UTC
The error from libvirt build (initiated by mbs for virt-rhel module):

DEBUG util.py:522:  Executing command: ['/usr/bin/dnf', 'builddep', '--installroot', '/mnt/build/mock/module-virt-rhel-820181217171651-9edba152-build-4632691-2930714/root/', '/mnt/build/mock/module-virt-rhel-820181217171651-9edba152-build-4632691-2930714/root//builddir/build/SRPMS/libvirt-4.5.0-16.module+el8+2576+af453261.src.rpm', '--setopt=tsflags=nocontexts'] with env {'LANG': 'en_US.UTF-8', 'TERM': 'vt100', 'SHELL': '/bin/bash', 'LC_MESSAGES': 'C', 'HOSTNAME': 'mock', 'PROMPT_COMMAND': 'printf "\\033]0;<mock-chroot>\\007"', 'HOME': '/builddir', 'PATH': '/usr/bin:/bin:/usr/sbin:/sbin', 'PS1': '<mock-chroot> \\s-\\v\\$ '} and shell False
DEBUG util.py:439:  Last metadata expiration check: 0:00:00 ago on Mon 17 Dec 2018 05:39:55 PM UTC.
DEBUG util.py:439:  Package gawk-4.2.1-1.el8.x86_64 is already installed, skipping.
DEBUG util.py:439:  Package gcc-8.2.1-3.5.el8.x86_64 is already installed, skipping.
DEBUG util.py:439:  Package util-linux-2.32.1-8.el8.x86_64 is already installed, skipping.
DEBUG util.py:439:  Error: 
DEBUG util.py:439:   Problem 1: conflicting requests
DEBUG util.py:439:    - nothing provides libnftnl.so.7()(64bit) needed by iptables-1.8.2-3.el8.x86_64
DEBUG util.py:439:   Problem 2: package iptables-ebtables-1.8.2-3.el8.x86_64 requires iptables = 1.8.2-3.el8, but none of the providers can be installed
DEBUG util.py:439:    - conflicting requests
DEBUG util.py:439:    - nothing provides libnftnl.so.7()(64bit) needed by iptables-1.8.2-3.el8.x86_64

Comment 5 Danilo Cesar Lemes de Paula 2018-12-18 11:09:33 UTC
Phil, could you give some priority to this, please?
We're have more than 20 packages blocked by this bug.

Comment 6 Danilo Cesar Lemes de Paula 2018-12-18 12:37:48 UTC
*** Bug 1660464 has been marked as a duplicate of this bug. ***

Comment 7 Florian Weimer 2018-12-18 12:46:52 UTC
Please note that nftables needs rebuilding as well.

Comment 8 Phil Sutter 2018-12-18 13:45:58 UTC
Hi Danilo,

(In reply to Danilo Cesar de Paula from comment #5)
> Phil, could you give some priority to this, please?
> We're have more than 20 packages blocked by this bug.

Should be all fixed now, sorry for the mess!


Note You need to log in before you can comment on or make changes to this bug.