Bug 1660279 - as from binutils 2.31.1 may fail at some certain condition
Summary: as from binutils 2.31.1 may fail at some certain condition
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: binutils
Version: 29
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Nick Clifton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-18 03:28 UTC by Kai
Modified: 2019-02-13 09:31 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-02-02 03:34:47 UTC


Attachments (Terms of Use)

Description Kai 2018-12-18 03:28:16 UTC
Description of problem:
On a certain condition, it fails to call as from binutils 2.31.1:
| Assembler messages: 
| Fatal error: The input and output files must be distinct 

It has been fixed in upstream:
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=commit;h=2a50366ded329bfb39d387253450c9d5302c3503

Would you like to cherry-pick the commit? Thanks.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Kai 2018-12-20 02:22:52 UTC
Steps to reproduce:

1 boot a Fedora 29 docker image, and mount /tmp with tmpfs for convenient:
$ docker run -it --mount type=tmpfs,destination=/tmp fedora:29 /bin/bash

2 check inode of /dev/null
$ stat -c %i /dev/null
6

and then create files under /tmp and make the biggest inode of files is 5.
$ stat -c %i `ls -t /tmp/* | head -1`
5

3 compile any assembly file with redirect output to /dev/null:
$ gcc -c -o /dev/null foo.S 
Assembler messages:
Fatal error: The input and output files must be distinct

Comment 2 Randy MacLeod 2019-01-29 20:09:04 UTC
Any update? We have a work-around for Yocot/oe-core but it would be nice to pull in the upstream commit and fix the issue for others. Should we keep checking on the defect or will it only be resolved when binutils is updated for new releases of Fedora?

Comment 3 Fedora Update System 2019-01-30 12:46:17 UTC
binutils-2.31.1-17.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-ba3cbcfd20

Comment 4 Nick Clifton 2019-01-30 12:48:46 UTC
Hi Randy,

  Sorry - this one slipped my queue.  I have now backported the patch to F29 and F30.

Cheers
  Nick

Fixed in: binutils-2.31.1-17.fc29 binutils-2.31.1-20.fc30

I have submitted a bodhi update request for this new version:

  https://bodhi.fedoraproject.org/updates/binutils-2.31.1-17.fc29

Comment 5 Fedora Update System 2019-01-31 02:30:11 UTC
binutils-2.31.1-17.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-ba3cbcfd20

Comment 6 Fedora Update System 2019-02-02 03:34:47 UTC
binutils-2.31.1-17.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Kai 2019-02-13 09:31:57 UTC
binutils-2.31.1-17 works for me. This defect could be closed. Thanks.


Note You need to log in before you can comment on or make changes to this bug.