Bug 166036 - Not mount local lvm2 partition with lvm2-cluster
Not mount local lvm2 partition with lvm2-cluster
Status: CLOSED DUPLICATE of bug 165787
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-15 23:22 EDT by Michael Musikhin
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 23:29:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Musikhin 2005-08-15 23:22:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
after install lvm2-cluster-2.01.09-5.0.RHEL4 
server not mount lvm2 not ROOTFS logical volumes 

Version-Release number of selected component (if applicable):
lvm2-2.01.08-1.0.RHEL4 lvm2-cluster-2.01.09-5.0.RHEL4 initscripts-7.93.13.EL-2

How reproducible:
Always

Steps to Reproduce:
Server configuration:
cat /etc/fstab
...
/dev/Volume00/ROOT      /                       ext3    defaults        1 1
/dev/VolMSA0003/STAT    /data                   ext3    defaults        1 2
...

after install lvm2-cluster-2.01.09-5.0.RHEL4 
server not mount /data on startup

Actual Results:  rc.sysinit scripts not execute 
"Setting up Logical Volume Management:"
and VolumeGroup VolMSA0003 not initialized
startup procedure stopped with
"type Ctrl-D or enter root password"

Expected Results:  Normal startup with mount /data filesystem

Additional info:

in rc.sysinit script not execute 
    if [ -c /dev/mapper/control -a -x /sbin/lvm.static ]; then
        if /sbin/lvm.static vgscan --mknodes --ignorelockingfailure > /dev/null 2>&1 ; then
            action $"Setting up Logical Volume Management:" /sbin/lvm.static vgchange -a y --ignorelockingfailure
        fi
    fi
lvm.static crash with error
liblvm2clusterlock.so: undefined symbol: print_log

we found solution this problem
we change lvm.static to lvm in rc.sysinit script
Comment 1 Michael Musikhin 2005-08-15 23:29:00 EDT

*** This bug has been marked as a duplicate of 165787 ***

Note You need to log in before you can comment on or make changes to this bug.