This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 166039 - ext2online can't resize: No space left on device
ext2online can't resize: No space left on device
Status: CLOSED DUPLICATE of bug 166038
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: e2fsprogs (Show other bugs)
4.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Thomas Woerner
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-15 23:50 EDT by Andre
Modified: 2015-01-07 19:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 23:53:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre 2005-08-15 23:50:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
ext2online resize failed:
2 out of 8 system I recently install are having a problem with ext2online
resizing.



Version-Release number of selected component (if applicable):
e2fsprogs-1.35-12.1.EL4
kernel-2.6.9-11.EL
lvm2-2.01.08-1.0.RHEL4
device-mapper-1.01.01-1.RHEL4

How reproducible:
Sometimes

Steps to Reproduce:
1. create lvm: pv, vg, lv
2. format the lv
3. mount the lv
4. lvextend -l +10 /dev/test0/scratch
5. ext2online /dev/test0/scratch
  

Actual Results:  # ext2online -v -d /dev/test0/scratch
ext2online v1.1.18 - 2001/03/18 for EXT2FS 0.5b
ext2_open
ext2_bcache_init
new filesystem size 61440
ext2_determine_itoffset
setting itoffset to +35
group 2 inode table has offset 2, not 35
group 4 inode table has offset 2, not 35
ext2_get_reserved
Found 31 blocks in s_reserved_gdt_blocks
using 31 reserved group descriptor blocks

5 old groups, 1 blocks
8 new groups, 1 blocks
ext2_ioctl: EXTEND group to 40961 blocks
creating group   5 with  8192 blocks (rsvd = 31, newgd =  1)
using itoffset of 35
new block bitmap is at 0xa022
new inode bitmap is at 0xa023
new inode table is at 0xa024-0xa123
new group has 7901 free blocks
new group has 2048 free inodes (256 blocks)
ext2_ioctl: ADD group 5
ext2online: ext2_ioctl: No space left on device

ext2online: unable to resize /dev/mapper/test0-scratch

Expected Results:  ext2online return success and
lv (lvdisplay) and fs (df) size should show the same size


Additional info:
Comment 1 Andre 2005-08-15 23:53:50 EDT

*** This bug has been marked as a duplicate of 166038 ***

Note You need to log in before you can comment on or make changes to this bug.