Bug 1660466 - [abrt] systemd: epoll_wait(): systemd-logind killed by SIGABRT
Summary: [abrt] systemd: epoll_wait(): systemd-logind killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 1300212
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:8b7e57cd33ecf7beeab8d619f05...
: 1607764 1674193 1680001 1680003 1680004 1680005 1691889 (view as bug list)
Depends On:
Blocks: systemd-journald-sigabrt, systemd-sigabrt
TreeView+ depends on / blocked
 
Reported: 2018-12-18 11:46 UTC by Patrick Thies
Modified: 2019-09-12 15:58 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-12 15:58:11 UTC


Attachments (Terms of Use)
File: backtrace (8.02 KB, text/plain)
2018-12-18 11:46 UTC, Patrick Thies
no flags Details
File: cgroup (328 bytes, text/plain)
2018-12-18 11:46 UTC, Patrick Thies
no flags Details
File: core_backtrace (1.21 KB, text/plain)
2018-12-18 11:46 UTC, Patrick Thies
no flags Details
File: cpuinfo (1.39 KB, text/plain)
2018-12-18 11:46 UTC, Patrick Thies
no flags Details
File: dso_list (3.97 KB, text/plain)
2018-12-18 11:46 UTC, Patrick Thies
no flags Details
File: environ (218 bytes, text/plain)
2018-12-18 11:46 UTC, Patrick Thies
no flags Details
File: limits (1.29 KB, text/plain)
2018-12-18 11:46 UTC, Patrick Thies
no flags Details
File: maps (21.19 KB, text/plain)
2018-12-18 11:46 UTC, Patrick Thies
no flags Details
File: mountinfo (3.54 KB, text/plain)
2018-12-18 11:46 UTC, Patrick Thies
no flags Details
File: open_fds (5.19 KB, text/plain)
2018-12-18 11:46 UTC, Patrick Thies
no flags Details
File: proc_pid_status (1.28 KB, text/plain)
2018-12-18 11:46 UTC, Patrick Thies
no flags Details
File: var_log_messages (960 bytes, text/plain)
2018-12-18 11:46 UTC, Patrick Thies
no flags Details

Description Patrick Thies 2018-12-18 11:46:08 UTC
Description of problem:
did a dnf upgrade --refresh
seems like that finished since no updates available on second try.

wayland crashed, too.

Version-Release number of selected component:
systemd-239-6.git9f3aed1.fc29

Additional info:
reporter:       libreport-2.9.7
backtrace_rating: 4
cmdline:        /usr/lib/systemd/systemd-logind
crash_function: epoll_wait
executable:     /usr/lib/systemd/systemd-logind
journald_cursor: s=a08bf4a22746434fbe471d593f1d2bfe;i=18011;b=c51f64a9d08f4eab81e9da6323ac533d;m=4cf17ea8;t=57d4a33e1a049;x=4472227a03c60313
kernel:         4.19.8-300.fc29.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (4 frames)
 #0 epoll_wait at ../sysdeps/unix/sysv/linux/epoll_wait.c:30
 #1 sd_event_wait at ../src/libsystemd/sd-event/sd-event.c:3397
 #2 sd_event_run at ../src/libsystemd/sd-event/sd-event.c:3566
 #3 manager_run at ../src/login/logind.c:1208

Potential duplicate: bug 1607764

Comment 1 Patrick Thies 2018-12-18 11:46:11 UTC
Created attachment 1515317 [details]
File: backtrace

Comment 2 Patrick Thies 2018-12-18 11:46:12 UTC
Created attachment 1515318 [details]
File: cgroup

Comment 3 Patrick Thies 2018-12-18 11:46:14 UTC
Created attachment 1515319 [details]
File: core_backtrace

Comment 4 Patrick Thies 2018-12-18 11:46:15 UTC
Created attachment 1515320 [details]
File: cpuinfo

Comment 5 Patrick Thies 2018-12-18 11:46:16 UTC
Created attachment 1515321 [details]
File: dso_list

Comment 6 Patrick Thies 2018-12-18 11:46:17 UTC
Created attachment 1515322 [details]
File: environ

Comment 7 Patrick Thies 2018-12-18 11:46:18 UTC
Created attachment 1515323 [details]
File: limits

Comment 8 Patrick Thies 2018-12-18 11:46:20 UTC
Created attachment 1515324 [details]
File: maps

Comment 9 Patrick Thies 2018-12-18 11:46:21 UTC
Created attachment 1515325 [details]
File: mountinfo

Comment 10 Patrick Thies 2018-12-18 11:46:23 UTC
Created attachment 1515326 [details]
File: open_fds

Comment 11 Patrick Thies 2018-12-18 11:46:29 UTC
Created attachment 1515327 [details]
File: proc_pid_status

Comment 12 Patrick Thies 2018-12-18 11:46:30 UTC
Created attachment 1515328 [details]
File: var_log_messages

Comment 13 vladlen.lerner 2019-02-09 18:08:33 UTC
*** Bug 1674193 has been marked as a duplicate of this bug. ***

Comment 14 aoellerer 2019-02-22 13:36:51 UTC
*** Bug 1680001 has been marked as a duplicate of this bug. ***

Comment 15 aoellerer 2019-02-22 13:41:42 UTC
*** Bug 1680003 has been marked as a duplicate of this bug. ***

Comment 16 Zbigniew Jędrzejewski-Szmek 2019-02-25 07:26:49 UTC
*** Bug 1607764 has been marked as a duplicate of this bug. ***

Comment 17 Zbigniew Jędrzejewski-Szmek 2019-02-25 07:27:40 UTC
There's no information apart from the backtrace, but if logind was killed in epoll_wait() then this is almost certainly the watchdog. Either the machine is extremely resource-starved or there's some kernel bug. With logs it might be possible to figure out the exact reason.

Comment 18 Zbigniew Jędrzejewski-Szmek 2019-02-25 07:31:38 UTC
*** Bug 1680004 has been marked as a duplicate of this bug. ***

Comment 19 Zbigniew Jędrzejewski-Szmek 2019-02-25 07:32:10 UTC
*** Bug 1680005 has been marked as a duplicate of this bug. ***

Comment 20 Patrick Thies 2019-02-25 13:44:16 UTC
(In reply to Zbigniew Jędrzejewski-Szmek from comment #17)
> There's no information apart from the backtrace, but if logind was killed in
> epoll_wait() then this is almost certainly the watchdog. Either the machine
> is extremely resource-starved or there's some kernel bug. With logs it might
> be possible to figure out the exact reason.

Produkt-SKU: 4240CTO
Produktname: ThinkPad T520

 - Intel Core i7-2670QM Processor (2.20 GHz, 6MB L3)
 - 15,6 Zoll FHD (1900 x 1080) Anti-Glare-Bildschirm mit LED-Hintergrundbeleuchtung, fähig für mobiles Breitband
 - NVIDIA NVS 4200M Graphics mit Optimus-Technologie, 1 GB DDR3-Speicher
 - 6 GB PC3-10600 DDR3-SDRAM 1.333 MHz SODIMM-Speicher (2 DIMMs)
 - Tastatur, Deutsch
 - Fingerabdruckleser
 - 720p Kamera
 - 128-GB-Solid-State-Laufwerk, SATA
 - Wiederbeschreibbare DVD
 - Express Card Slot & 4 in 1 Card Reader & Smart Card Reader
 - Lithium-Ionen-Akku mit 9 Zellen (2,8 Ah) - Dual-Modus
 - Länderspezifisches Paket Deutschland mit Netzkabel und 135-W-Netzteil
 - Bluetooth 3.0
 - Intel Centrino Ultimate-N 6300 (3x3 AGN)
 - Integriertes mobiles Breitband - Upgrade möglich
 - Sprachenpaket WE (FR/GE/IT/IT/DU/EN)

Produkt-SKU: 0A90204
Produktname: ThinkPad Mini Dock Plus Series 3 (170W) (EU)

Comment 21 aoellerer 2019-02-25 15:11:51 UTC
Yeah, I was training a GAN while this happened, so guess it's resource starvation.

Comment 22 vladlen.lerner 2019-03-22 18:24:42 UTC
*** Bug 1691889 has been marked as a duplicate of this bug. ***

Comment 23 robert fairbrother 2019-05-31 03:46:46 UTC
Similar problem has been detected:

happened same time as this https://bugzilla.redhat.com/show_bug.cgi?id=1567645

reporter:       libreport-2.10.0
backtrace_rating: 4
cmdline:        /usr/lib/systemd/systemd --user
crash_function: epoll_wait
executable:     /usr/lib/systemd/systemd
journald_cursor: s=f82b3db13754497e9310ee2fd027e3bb;i=2b85;b=50f26a9fd7d644b2abe679f36a10238a;m=486aa9a1;t=58a24e9932b2c;x=8a1dd58786689bef
kernel:         5.0.17-200.fc29.x86_64
package:        systemd-239-12.git8bca462.fc29
reason:         systemd killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 24 robert fairbrother 2019-08-18 04:52:43 UTC
Similar problem has been detected:

may be related to https://bugzilla.redhat.com/show_bug.cgi?id=1742964

reporter:       libreport-2.10.1
backtrace_rating: 4
cmdline:        /usr/lib/systemd/systemd --user
crash_function: epoll_wait
executable:     /usr/lib/systemd/systemd
journald_cursor: s=a7dd7143bbf24a11a31720a31072c1ce;i=2fab;b=107aa183c55d4d5cb34f675b25a55b34;m=d12dd5dd1;t=590471dbeb011;x=2560334f8cad6fe3
kernel:         5.2.7-100.fc29.x86_64
package:        systemd-239-13.gitf4afb95.fc29
reason:         systemd killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 25 Zbigniew Jędrzejewski-Szmek 2019-09-12 15:58:11 UTC

*** This bug has been marked as a duplicate of bug 1300212 ***


Note You need to log in before you can comment on or make changes to this bug.