Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1660551 - stunnel -options lists options that are not supported
Summary: stunnel -options lists options that are not supported
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: stunnel
Version: 8.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Sahana Prasad
QA Contact: Ivan Nikolchev
URL:
Whiteboard:
Depends On: 1682510
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-18 15:32 UTC by Hubert Kario
Modified: 2020-11-04 01:34 UTC (History)
3 users (show)

Fixed In Version: stunnel-5.56-1.el8
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-04 01:32:21 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4440 0 None None None 2020-11-04 01:32:26 UTC

Description Hubert Kario 2018-12-18 15:32:33 UTC
Description of problem:
`stunnel -options` lists options that can't be used in configuration file

Version-Release number of selected component (if applicable):
stunnel-5.48-5.el8.x86_64

How reproducible:
always

Steps to Reproduce:
1. stunnel -options 2>&1 | grep NETSCAPE_REUSE_CIPHER_CHANGE_BUG
2. configure stunnel with the above option
3.

Actual results:
the option is listed, server fails with following error:
[!] /tmp/tmp.jmI72ywq7F/stunnel.conf:12: "options=NETSCAPE_REUSE_CIPHER_CHANGE_BUG": Illegal TLS option

Expected results:
option not listed in command output

Additional info:
I haven't checked other options, but stunnel -options should only list options that are actually usable

Comment 2 Sahana Prasad 2020-03-31 13:22:11 UTC
This issue will be fixed with rebase of stunnel to latest upstream version (5.56). The rebase will be done with https://bugzilla.redhat.com/show_bug.cgi?id=1808365.
I have tested this case on f31 (with stunnel 5.56) using downstream testcase stunnel/Sanity/smoke-test by modifying the server.conf to include the parameter 
"options = NETSCAPE_REUSE_CIPHER_CHANGE_BUG". The test case is found to be passing.

Comment 10 errata-xmlrpc 2020-11-04 01:32:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (stunnel bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4440


Note You need to log in before you can comment on or make changes to this bug.