Bug 1660597 - jabber.sugarlabs.org does not show XO 's in f1 Network neighborhood
Summary: jabber.sugarlabs.org does not show XO 's in f1 Network neighborhood
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sugar
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Simon Schampijer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F30FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2018-12-18 18:55 UTC by satellitgo
Modified: 2019-04-25 19:33 UTC (History)
9 users (show)

Fixed In Version: sugar-0.113-2.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-25 19:33:36 UTC


Attachments (Terms of Use)
faiure of liveinst in soas rawhide (95.88 KB, image/png)
2019-01-03 23:27 UTC, satellitgo
no flags Details


Links
System ID Priority Status Summary Last Updated
Github sugarlabs sugar issues 814 None None None 2018-12-18 23:03:04 UTC

Description satellitgo 2018-12-18 18:55:43 UTC
Description of problem: jabber.sugarlabs.org does not show XO 's in f1 Network neighborhood


Version-Release number of selected component (if applicable):
connect to prosody "telnet jabber.sugarlabs.org 5222"
...
connected

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
no XO shown
Expected results:


Additional info:

Comment 1 satellitgo 2018-12-18 18:57:07 UTC
f29 final release Soas spin

Comment 2 Robert Scheck 2018-12-18 20:28:48 UTC
Can you please provide some real technical details? As of writing this could be also a firewall misconfiguration on the client or server and thus be completely unrelated to Prosody. Which version of Prosody are you using? What does /var/log/prosody/prosody.log on the server say?

Comment 3 Robert Scheck 2018-12-18 23:03:59 UTC
The logs provided on GitHub are client logs only, not server logs. And they still do not answer any of my questions in comment #2.

Comment 4 Robert Scheck 2018-12-18 23:11:21 UTC
From my point of view, this is a pure client issue (thus not prosody related), thus re-assigning to "sugar".

Comment 5 satellitgo 2018-12-19 12:36:23 UTC
https://github.com/sugarlabs/sugar/issues/814

Comment 6 satellitgo 2018-12-20 10:30:23 UTC
https://wiki.sugarlabs.org/go/File:Ssh_err_in_oracle.png

pwemission denied public key

Oracle VirtualBox install

Comment 7 satellitgo 2019-01-03 23:27:55 UTC
Created attachment 1518287 [details]
faiure of liveinst in soas rawhide

not able to connect to dbus ?

Comment 8 satellitgo 2019-01-03 23:30:53 UTC
(In reply to satellitgo from comment #7)
> Created attachment 1518287 [details]
> faiure of liveinst in soas rawhide
> 
> not able to connect to dbus ?

Fedora-KDE-Live-x86_64-Rawhide-20190102.n.0.iso  installed correctly

Comment 9 satellitgo 2019-02-21 00:09:05 UTC
still in Fedora-SoaS-Live-x86_64-30-20190220.n.0.iso

first branched f30

Comment 10 Fedora Update System 2019-04-20 08:25:40 UTC
sugar-0.113-1.fc30 sugar-artwork-0.113-1.fc30 sugar-browse-203-1.fc30 sugar-chat-85-1.fc30 sugar-clock-21-1.fc30 sugar-datastore-0.113-1.fc30 sugar-getiabooks-18.2-1.fc30 sugar-log-40-1.fc30 sugar-read-122-1.fc30 sugar-terminal-46-1.fc30 sugar-toolkit-gtk3-0.113-1.fc30 sugar-turtleart-218-2.fc30 sugar-write-100-1.fc30 xapian-bindings-1.4.10-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-98a501f843

Comment 11 Fedora Update System 2019-04-20 14:42:23 UTC
sugar-0.113-1.fc30, sugar-artwork-0.113-1.fc30, sugar-browse-203-1.fc30, sugar-chat-85-1.fc30, sugar-clock-21-1.fc30, sugar-datastore-0.113-1.fc30, sugar-getiabooks-18.2-1.fc30, sugar-log-40-1.fc30, sugar-read-122-1.fc30, sugar-terminal-46-1.fc30, sugar-toolkit-gtk3-0.113-1.fc30, sugar-turtleart-218-2.fc30, sugar-write-100-1.fc30, xapian-bindings-1.4.10-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-98a501f843

Comment 12 Fedora Update System 2019-04-22 06:56:04 UTC
sugar-0.113-1.fc30 sugar-artwork-0.113-1.fc30 sugar-browse-203-1.fc30 sugar-chat-85-1.fc30 sugar-clock-21-1.fc30 sugar-datastore-0.113-1.fc30 sugar-getiabooks-18.2-1.fc30 sugar-log-40-1.fc30 sugar-read-122-1.fc30 sugar-terminal-46-1.fc30 sugar-toolkit-gtk3-0.113-2.fc30 sugar-turtleart-218-2.fc30 sugar-write-100-1.fc30 xapian-bindings-1.4.10-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-98a501f843

Comment 13 Fedora Update System 2019-04-22 14:22:52 UTC
sugar-0.113-1.fc30, sugar-artwork-0.113-1.fc30, sugar-browse-203-1.fc30, sugar-chat-85-1.fc30, sugar-clock-21-1.fc30, sugar-datastore-0.113-1.fc30, sugar-getiabooks-18.2-1.fc30, sugar-log-40-1.fc30, sugar-read-122-1.fc30, sugar-terminal-46-1.fc30, sugar-toolkit-gtk3-0.113-2.fc30, sugar-turtleart-218-2.fc30, sugar-write-100-1.fc30, xapian-bindings-1.4.10-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-98a501f843

Comment 14 Fedora Update System 2019-04-22 20:00:42 UTC
sugar-0.113-2.fc30 sugar-artwork-0.113-1.fc30 sugar-browse-203-1.fc30 sugar-chat-85-1.fc30 sugar-clock-21-1.fc30 sugar-datastore-0.113-1.fc30 sugar-getiabooks-18.2-1.fc30 sugar-log-40-1.fc30 sugar-read-122-1.fc30 sugar-terminal-46-1.fc30 sugar-toolkit-gtk3-0.113-2.fc30 sugar-turtleart-218-2.fc30 sugar-write-100-1.fc30 xapian-bindings-1.4.10-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-98a501f843

Comment 15 Fedora Update System 2019-04-23 14:55:34 UTC
sugar-0.113-2.fc30, sugar-artwork-0.113-1.fc30, sugar-browse-203-1.fc30, sugar-chat-85-1.fc30, sugar-clock-21-1.fc30, sugar-datastore-0.113-1.fc30, sugar-getiabooks-18.2-1.fc30, sugar-log-40-1.fc30, sugar-read-122-1.fc30, sugar-terminal-46-1.fc30, sugar-toolkit-gtk3-0.113-2.fc30, sugar-turtleart-218-2.fc30, sugar-write-100-1.fc30, xapian-bindings-1.4.10-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-98a501f843

Comment 16 satellitgo 2019-04-23 15:00:04 UTC
works in f30 sugar .113  see   https://bodhi.fedoraproject.org/updates/FEDORA-2019-98a501f843

Comment 17 Fedora Blocker Bugs Application 2019-04-23 15:13:14 UTC
Proposed as a Freeze Exception for 30-final by Fedora user satellit using the blocker tracking app because:

 sugar .113 fixes this after patch
non blocking DE and would fix a problem of jabber.sugarlabs.or not working. (a main feature) see comment #16

Comment 19 Adam Williamson 2019-04-23 15:49:01 UTC
+1 FE (especially as Sugar is mainly intended to be run live).

Comment 20 Julen Landa Alustiza 2019-04-23 17:33:26 UTC
+1 FE

Comment 21 Mohan Boddu 2019-04-23 22:46:33 UTC
+1 FE

Comment 22 Adam Williamson 2019-04-23 22:51:15 UTC
That's +3, marking accepted.

Comment 23 Fedora Update System 2019-04-25 19:33:36 UTC
sugar-0.113-2.fc30, sugar-artwork-0.113-1.fc30, sugar-browse-203-1.fc30, sugar-chat-85-1.fc30, sugar-clock-21-1.fc30, sugar-datastore-0.113-1.fc30, sugar-getiabooks-18.2-1.fc30, sugar-log-40-1.fc30, sugar-read-122-1.fc30, sugar-terminal-46-1.fc30, sugar-toolkit-gtk3-0.113-2.fc30, sugar-turtleart-218-2.fc30, sugar-write-100-1.fc30, xapian-bindings-1.4.10-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.