Bug 1660610 - printing text files fails because ghostscript cannot find the font
Summary: printing text files fails because ghostscript cannot find the font
Keywords:
Status: CLOSED DUPLICATE of bug 1653706
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ghostscript
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Martin Osvald 🛹
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-18 19:36 UTC by Andrew Schorr
Modified: 2018-12-20 02:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-20 02:54:25 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Andrew Schorr 2018-12-18 19:36:44 UTC
Description of problem:
When I try to print a plain text file, nothing comes out of the printer. If I change the LogLevel in cupsd.conf to debug, I see error messages in /var/log/cups/error_log saying "Error: /typecheck in /findfont". It seems that
the Postscript is generated by paps. I get a similar error when I run
"head /etc/passwd | paps | gs -".

Version-Release number of selected component (if applicable):
paps-0.6.8-28.el7.1.x86_64


How reproducible:
Always.

Steps to Reproduce:
1. head /etc/passwd | lpr
2. or 
3. head /etc/passwd | paps | gs -

Actual results:
Error messages, and nothing is printed. Here's what I see:
bash-4.2$ head /etc/passwd | paps | gs -
GPL Ghostscript 9.07 (2013-02-14)
Copyright (C) 2012 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Can't find (or can't open) font file /usr/share/ghostscript/9.07/Resource/Font/NimbusSanL-Regu.
Can't find (or can't open) font file NimbusSanL-Regu.
Can't find (or can't open) font file /usr/share/ghostscript/9.07/Resource/Font/NimbusSanL-Regu.
Can't find (or can't open) font file NimbusSanL-Regu.
Querying operating system for font files...
Error: /typecheck in /findfont
Operand stack:
   Helvetica
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1884   1   3   %oparray_pop   1883   1   3   %oparray_pop   1867   1   3   %oparray_pop   1755   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   1836   1   5   %oparray_pop
Dictionary stack:
   --dict:950/1684(ro)(G)--   --dict:0/20(G)--   --dict:78/200(L)--   --dict:27/42(L)--   --dict:11/11(L)--
Current allocation mode is local
GPL Ghostscript 9.07: Unrecoverable error, exit code 1

That's very similar to what I see in /var/log/cups/error_log, except it doesn't specify which fonts are not found. In error_log, I see:
D [18/Dec/2018:14:23:23 -0500] [Job 139] Before copy_comments - %!PS-Adobe-3.0
D [18/Dec/2018:14:23:23 -0500] [Job 139] %!PS-Adobe-3.0
D [18/Dec/2018:14:23:23 -0500] [Job 139] %cupsRotation: 0
D [18/Dec/2018:14:23:23 -0500] [Job 139] %%Title: (stdin)
D [18/Dec/2018:14:23:23 -0500] [Job 139] %%Creator: paps version 0.6.7 by Dov Gr
obgeld
D [18/Dec/2018:14:23:23 -0500] [Job 139] %%Pages: (atend)
D [18/Dec/2018:14:23:23 -0500] [Job 139] %%BoundingBox: 0 0 612 792
D [18/Dec/2018:14:23:23 -0500] [Job 139] %%For: schorr
D [18/Dec/2018:14:23:23 -0500] [Job 139] %%Orientation: Portrait
D [18/Dec/2018:14:23:23 -0500] [Job 139] %%EndComments
D [18/Dec/2018:14:23:23 -0500] [Job 139] Before copy_prolog - %%BeginProlog
D [18/Dec/2018:14:23:23 -0500] [Job 139] Before copy_setup - %%BeginSetup
D [18/Dec/2018:14:23:23 -0500] [Job 139] Before page loop - %%Page: 1 1
D [18/Dec/2018:14:23:23 -0500] [Job 139] Copying page 1...
D [18/Dec/2018:14:23:23 -0500] [Job 139] pagew = 588.0, pagel = 768.0
D [18/Dec/2018:14:23:23 -0500] [Job 139] bboxx = 0, bboxy = 0, bboxw = 612, bbox
l = 792
D [18/Dec/2018:14:23:23 -0500] [Job 139] PageLeft = 12.0, PageRight = 600.0
D [18/Dec/2018:14:23:23 -0500] [Job 139] PageTop = 780.0, PageBottom = 12.0
D [18/Dec/2018:14:23:23 -0500] [Job 139] PageWidth = 612.0, PageLength = 792.0
D [18/Dec/2018:14:23:23 -0500] [Job 139] Wrote 1 pages...
D [18/Dec/2018:14:23:23 -0500] [Job 139] Error: /typecheck in /findfont
D [18/Dec/2018:14:23:23 -0500] [Job 139] Operand stack:
D [18/Dec/2018:14:23:23 -0500] [Job 139] Helvetica
...

Expected results:
It should work!

Additional info: I am not certain which component is at fault, but clearly it cannot find the fonts that it wants.

Comment 2 Akira TAGOH 2018-12-19 03:20:37 UTC
Simple reproducible code should be:
$ echo "/Helvetica findfont" | gs

If you still see the error, please check if you have WOFF fonts in the font paths or so which ghostscript doesn't support. see Bug#1653706

Comment 3 Andrew Schorr 2018-12-19 14:11:27 UTC
bash-4.2$ echo "/Helvetica findfont" | gs
GPL Ghostscript 9.07 (2013-02-14)
Copyright (C) 2012 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
GS>Can't find (or can't open) font file /usr/share/ghostscript/9.07/Resource/Font/NimbusSanL-Regu.
Can't find (or can't open) font file NimbusSanL-Regu.
Can't find (or can't open) font file /usr/share/ghostscript/9.07/Resource/Font/NimbusSanL-Regu.
Can't find (or can't open) font file NimbusSanL-Regu.
Querying operating system for font files...
Error: /typecheck in /findfont
Operand stack:
   Helvetica
Execution stack:
   %interp_exit   .runexec2   --nostringval--   .findfontop   --nostringval--   2   %stopped_push   --nostringval--   .findfontop   %loop_continue   .findfontop   .findfontop   false   1   %stopped_push   .runexec2   --nostringval--   .findfontop   --nostringval--   2   %stopped_push   --nostringval--   1842   1   3   %oparray_pop
Dictionary stack:
   --dict:950/1684(ro)(G)--   --dict:0/20(G)--   --dict:77/200(L)--
Current allocation mode is local
Current file position is 20
GS<1>bash-4.2$ 

bash-4.2$ fc-list | grep -i woff
/usr/share/fonts/fontawesome/fontawesome-webfont.woff: FontAwesome:style=Regular

Is there any fix for this other than removing the rpm containing the woff file?

Comment 4 Andrew Schorr 2018-12-19 17:54:00 UTC
FYI, I can confirm that removing the fontawesome-fonts-web rpm solves my problem.
I can now print text files again.

Comment 5 Akira TAGOH 2018-12-20 02:54:25 UTC
See the bug in my last comment. this issue has already been fixed in ghostscript upstream.

*** This bug has been marked as a duplicate of bug 1653706 ***


Note You need to log in before you can comment on or make changes to this bug.