Bug 166070 - regression in evince's displaying of LaTeX-generated tables
regression in evince's displaying of LaTeX-generated tables
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
http://www.lsd.ic.unicamp.br/~oliva/p...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-16 13:07 EDT by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 00:36:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
What I see (37.48 KB, image/png)
2005-08-16 13:26 EDT, Tejas Dinkar
no flags Details
Broken rendering from rawhide (74.76 KB, image/png)
2005-08-16 14:06 EDT, Alexandre Oliva
no flags Details

  None (edit)
Description Alexandre Oliva 2005-08-16 13:07:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8b3) Gecko/20050729 Fedora/1.1-0.2.5.deerpark.alpha2 Firefox/1.0+

Description of problem:
If you browse to page 13 of the PDF presentation mentioned in the bug's URL, using evince 0.3.2-2, you'll see a table that looks very odd: some horizontal lines in the table extend all the way to the left margin, while others are barely visible.  Vertical lines extend a bit lower than they should.  Also, there's some barely visible background on most pages that shouldn't be there; it's supposed to be uniform.  None of these problems are present with evince in FC4.

Version-Release number of selected component (if applicable):
evince-0.3.2-2

How reproducible:
Always

Steps to Reproduce:
1.Open the PDF presentation in the bug's URL with rawhide's evince
2.Browse to page 13

Actual Results:  The lines that form the table are all messed up, and there are some unintended abstract-painting-like background.

Expected Results:  The page should be displayed just like FC4's evince did.

Additional info:
Comment 1 Tejas Dinkar 2005-08-16 13:26:37 EDT
Created attachment 117795 [details]
What I see
Comment 2 Tejas Dinkar 2005-08-16 13:28:27 EDT
This appears to work in evince 0.3.1 in FC4 2.6.11 kernel

See screenshot in the last comment
Comment 3 Alexandre Oliva 2005-08-16 14:06:36 EDT
Created attachment 117799 [details]
Broken rendering from rawhide

I did mention it worked on FC4.  This is what I get on yesterday's rawhide.
Comment 4 Rahul Sundaram 2005-08-17 06:05:22 EDT
Ok. Thanks for the screenshot people. changing status to assigned
Comment 5 Alexandre Oliva 2006-02-28 21:23:02 EST
Still broken in rawhide :-(  Is FC5's evince going to be unusable for
presentations, and I'm going to have to explain to people every time I deliver a
presentation why I don't use it, and use and recommend xpdf instead? :-/
Comment 6 Alexandre Oliva 2006-03-28 13:55:28 EST
There appears to have been some debatable progress: now it displays some of the
lines correctly, and some others not at all :-/
Comment 7 Alexandre Oliva 2006-06-17 14:29:04 EDT
Still broken in rawhide :-(
Comment 8 Alexandre Oliva 2006-07-27 00:36:23 EDT
Yay, this appears to be fixed!

Note You need to log in before you can comment on or make changes to this bug.