Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1660734 - Add glance cache-manage utility
Summary: Add glance cache-manage utility
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M3
: 15.0 (Stein)
Assignee: Abhishek Kekane
QA Contact: Mike Abrams
Kim Nylander
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-19 05:53 UTC by Abhishek Kekane
Modified: 2019-09-26 10:47 UTC (History)
2 users (show)

Fixed In Version: openstack-glance-18.0.1-0.20190420013840.f772321.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:19:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 626097 0 'None' MERGED Add cache-manage utility using v2 API 2020-03-27 05:15:54 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:20:11 UTC

Description Abhishek Kekane 2018-12-19 05:53:46 UTC
Description of problem:

In Rocky, the v1 dependent glance-cache-manage command was removed while removing Images API v1 entry points.

In Stein, as per Edge computing architecture, glance cache will be enabled on far-edge nodes. Hence it will be good to add glance-cache-manage utility using v2 API in glance. This utility will have the same interface as Queens glance-cache-manage utility [0] so far as possible.

[0] https://docs.openstack.org/glance/queens/cli/glancecachemanage.html


Version-Release number of selected component (if applicable):
15

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Abhishek Kekane 2018-12-19 05:55:38 UTC
Upstream Blueprint: https://blueprints.launchpad.net/glance/+spec/cache-manage

Upstream specs-lite: https://review.openstack.org/#/c/609331
Approved and merged.

Comment 3 Abhishek Kekane 2018-12-19 06:29:38 UTC
Patch submitted to master branch.
https://review.openstack.org/626097 Add cache-manage utility using v2 API

Comment 14 errata-xmlrpc 2019-09-21 11:19:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.