Bug 1660754 - systemd-resolved support in RHEL8
Summary: systemd-resolved support in RHEL8
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: systemd
Version: 8.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: 8.0
Assignee: systemd-maint
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-19 07:16 UTC by Ravindra Patil
Modified: 2018-12-20 11:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-20 11:41:22 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Ravindra Patil 2018-12-19 07:16:04 UTC
Description of problem:

The systemd-version in RHEL7 provides systemd-resolved package through optional repos. 

I would like to test some newer features like the "stub-server" in systemd-resolved.

Currently, there is no systemd-resolved package available within  RHEL 8.0 beta:

- Will systemd-resolved  be dropped totally in RHEL 8?
or...
- Is it "delayed" in the RHEL 8.0 beta?


Version-Release number of selected component (if applicable):

systemd-239-8.el8.x86_64

How reproducible:
1. Install RHEL 8.0 beta 
2. check systemd-resolved 

Actual results:
systemd-resolved is not available

Expected results:
systemd-resolved should be available

Additional info:

Comment 1 Michal Sekletar 2018-12-20 11:41:22 UTC
systemd-resolved should be available in RHEL-8 Beta. Binaries and service file are provided by systemd package and you don't need to install any additional packages.

This is what I see on RHEL-8 system (not a beta though but there shouldn't be any difference wrt. resolved)

[root@host-8-252-168 ~]# rpm -qf /usr/lib/systemd/system/systemd-resolved.service
systemd-239-10.el8.x86_64
[root@host-8-252-168 ~]# systemctl start systemd-resolved
[root@host-8-252-168 ~]# systemctl status systemd-resolved
● systemd-resolved.service - Network Name Resolution
   Loaded: loaded (/usr/lib/systemd/system/systemd-resolved.service; disabled; vendor preset: disabled)
   Active: active (running) since Thu 2018-12-20 06:33:25 EST; 4s ago
     Docs: man:systemd-resolved.service(8)
           https://www.freedesktop.org/wiki/Software/systemd/resolved
           https://www.freedesktop.org/wiki/Software/systemd/writing-network-configuration-managers
           https://www.freedesktop.org/wiki/Software/systemd/writing-resolver-clients
 Main PID: 6221 (systemd-resolve)
   Status: "Processing requests..."
    Tasks: 1 (limit: 11532)
   Memory: 3.4M
   CGroup: /system.slice/systemd-resolved.service
           └─6221 /usr/lib/systemd/systemd-resolved


Note You need to log in before you can comment on or make changes to this bug.