This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 166076 - Unresolved dependancy for httpd (Apache) in RHEL4 upgrade
Unresolved dependancy for httpd (Apache) in RHEL4 upgrade
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: httpd (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-16 13:57 EDT by Brian McEntire
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-16 17:00:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian McEntire 2005-08-16 13:57:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050719 Red Hat/1.7.10-1.4.1

Description of problem:
Upgraded a vanilla RHEL 3 WS system to RHEL 4u1 today. After upgrading also applied all errata with 'up2date -u --nox'.

After this upgrade, httpd would fail to start with:

Starting httpd: /usr/sbin/httpd: error while loading shared libraries:
libldap.so.2: cannot open shared object file: No such file or directory
                                                           [FAILED]

ldd revealed that a library that httpd is linked against is missing from the upgraded system:

[root@niagara conf]# ldd /usr/sbin/httpd|grep ldap
        libldap-2.2.so.7 => /usr/lib/libldap-2.2.so.7 (0x00111000)
        libldap.so.2 => not found


This was easily solved by installing compat-openldap from RHN however, it seems like a bug in the upgrade process / an unresolved dependancy. compat-openldap should be added to the system during the upgrade if httpd is installed.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Install vanilla RHEL 3 WS, install httpd, apply all errata
2. Upgrade to RHEL 4u2, apply all errata
3. Try to start httpd with 'service httpd start'
  

Actual Results:  Starting httpd: /usr/sbin/httpd: error while loading shared libraries:
libldap.so.2: cannot open shared object file: No such file or directory
                                                           [FAILED]


Expected Results:  httpd should start

Additional info:

Perhaps this bug belongs to a different componenet besides httpd, if so, please reassign it and I appologize. Something more specific to the upgrade process might be appropriate, or maybe httpd shouldn't rely on compat-openldap?
Comment 1 Joe Orton 2005-08-16 16:30:05 EDT
The likely cause of this is that the system had a third-party apr-util package
installed before the upgrade, is that the case here?  What's the output of:

# rpm -q apr-util
# rpm -ql apr-util

Comment 2 Brian McEntire 2005-08-16 16:47:11 EDT
You are right!

# rpm -q apr-util
apr-util-0.9.5-0.3

# rpm -ql apr-util
/usr/lib/libaprutil-0.so.0
/usr/lib/libaprutil-0.so.0.9.5
/usr/share/doc/apr-util-0.9.5
/usr/share/doc/apr-util-0.9.5/CHANGES
/usr/share/doc/apr-util-0.9.5/LICENSE


Should these be removed now? Is it something the upgrade could remove or
automatically select the compat-openldap package if they are installed?
Comment 3 Joe Orton 2005-08-16 17:00:48 EDT
Yes, download the proper RHEL4 apr-util package (e.g. using "upd2ate --get
apr-util"), then upgrade to it using:

   rpm -Uvh --oldpackage apr-util.*.rpm

(and the same for apr-util-devel if you have that installed too)

There's not much the installer can do to cope with this situation unfortunately.
 Even if the compat-openldap package *was* pulled in, you still have a broken
system since you'd get two different copies of OpenLDAP linked into httpd.

Note You need to log in before you can comment on or make changes to this bug.