Bug 166086 - Sound doesn't work after logout in a second concurrent session
Sound doesn't work after logout in a second concurrent session
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-16 16:02 EDT by Robin Green
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 05:31:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2005-08-16 16:02:12 EDT
Description of problem:
If I start a new X session on my computer on X screen :1 so that another member
of my family can use my computer, after that session finishes and I go back to
my session, alsa sound doesn't work any more.

The cause seems to be that a couple of config files are deleted on logout.

Version-Release number of selected component (if applicable):
alsa-lib-1.0.9rf-3

How reproducible:
Always

Steps to Reproduce (I haven't tried to reduce this to something simpler):
1. Log in to X as root.
2. Create a new user called "testsound" and give it a password.
3. Switch to a spare text-mode virtual terminal.
4. Log in on that terminal as "testsound"
5. Type startx -- :1 to start a new X session.
6. End the X session.
7. Log out on the virtual terminal.
8. Switch back to your root desktop.
9. Attempt to launch an application that uses ALSA, e.g. mplayer
  
Actual results:
Sound fails to play. The following errors appear on the console:

alsa-init: 1 soundcard found, using: default
ALSA lib conf.c:1578:(snd_config_load1) _toplevel_:51:23:No such file or directory
ALSA lib conf.c:2823:(snd_config_hook_load) /etc/alsa/cards/aliases.conf may be
old or corrupted: consider to remove or fix it
ALSA lib conf.c:2686:(snd_config_hooks_call) function snd_config_hook_load
returned error: No such file or directory
ALSA lib pcm.c:1959:(snd_pcm_open_conf) Invalid type for PCM default definition
(id: default, value: cards.pcm.default)
alsa-init: playback open error: Invalid argument
Could not open/initialize audio device -> no sound.

Expected results:
Sound should play.

Additional info:
My default desktop, which I use in all sessions, is KDE.
rpm -V alsa-lib before step 1 gives no output.
rpm -V alsa-lib after logging out of testsound shows:
missing   c /etc/alsa/pcm/dmix.conf
missing   c /etc/alsa/pcm/dsnoop.conf

Workaround:
Reinstall alsa-lib rpm with rpm -ivh --force [location of rpm file]
Comment 1 Martin Stransky 2005-10-05 05:31:52 EDT
Yes, it's because we use the console lock to control which users can use the
soundcard. And this is back-side of power. You can lauch system-config-soundcard
and set "Use only the HW device" and your card should work for all users.

Note You need to log in before you can comment on or make changes to this bug.