Bug 166090 - Cloned bugs only take the first portion of a bug information (the opened by section)
Cloned bugs only take the first portion of a bug information (the opened by s...
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-16 16:33 EDT by Suzanne Hillman
Modified: 2013-06-23 23:02 EDT (History)
0 users

See Also:
Fixed In Version: 2.18
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-01 14:48:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2005-08-16 16:33:24 EDT
Description of problem:
When one clones a bug, it only takes the first portion of a bug, that which
includes the information about who opened the bug. This is a problem in many
cases, where there's additional information about the bug in later comments. I
suggest either allowing people to select which additional comments they want in
a bug to be cloned, or capturing the entire bug, and not just the initial section.

How reproducible:
Always

Steps to Reproduce:
1. Find a bug you want to clone against another release, which has information
in the comments that should be in the clone as well.
2. Clone it.
3. There is only the initial problem description field (the opened by part) in
the cloned bug, none of the later comments.
  
Actual results:
Information is lost and needs to be propagated by hand.

Expected results:
Comments are propagated as well, either by selecting them, or all of them at the
point of cloning.

Additional info:
A developer complained about this problem as relating to bugs escalated from
Issue Tracker, since the initial problem description field only says where a bug
came from, and the later comments contain the main information. I am also going
to put a bug against Issue Tracker about that fact, as that seems not quite right.
Comment 1 David Lawrence 2005-08-23 13:34:22 EDT
Changed added in /bugzilla-devel. All comments should be now in the comment
field. Please verify this is working with a bug that you need to clone. It is
pointing at the live db so it is ok to try one that is a real change.

https://bugzilla.redhat.com/bugzilla-devel
Comment 2 Suzanne Hillman 2005-08-24 13:20:06 EDT
Oooh. Pretty. I don't tend to need to clone bugs of late, though. I shall ping
the engineer who mentioned this to me, and see if he has anything to test with.
Comment 3 Suzanne Hillman 2005-08-24 13:30:46 EDT
Hmm. Seems to still only take the initial problem description. Does it get
confused by private comments? (it shouldn't, since IT escalated bugs are almost
certainly going to have them) See bug #166689, which was cloned as bug #166690.
Comment 4 David Lawrence 2005-08-24 13:40:17 EDT
Strange, I go to 166689, click on Clone Bug, choose product (RHEL), and the
comment field shows the initial description plus the next two comments for me.
Did you scroll down in the comment box on the entry page to verify that the two
additional comments were there?
Comment 5 Suzanne Hillman 2005-08-24 15:08:27 EDT
If entry page = page immediately before submitting the bug, I did scroll down,
but did not realize that I should have seen the other comments then. I did not
see them then.

Note You need to log in before you can comment on or make changes to this bug.