Bug 166097 - /proc/acpi empty
/proc/acpi empty
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
: Regression
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2005-08-16 17:56 EDT by Kyrre Ness Sjøbæk
Modified: 2015-01-04 17:21 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 05:14:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot log for kernel 2.6.11 (8.52 KB, text/plain)
2005-09-17 04:35 EDT, Thomas Fischer
no flags Details
boot log for kernel 2.6.12 (13.72 KB, text/plain)
2005-09-17 04:36 EDT, Thomas Fischer
no flags Details
Kernel 2.6.11 boot message log (16.10 KB, text/plain)
2005-09-19 03:34 EDT, Thomas Fischer
no flags Details

  None (edit)
Description Kyrre Ness Sjøbæk 2005-08-16 17:56:16 EDT
Description of problem:
In kernel versions later than 2.6.12-1.1422_FC5, i have no files in /proc/acpi.
This means i cannot suspend my computer (at least not by the usual """cat "3" >
/proc/acpi/sleep"""). Nevertheless, auto fan controll, acpi buttons, and battery
monitor still seems to work.

Version-Release number of selected component (if applicable):
Greater than 2.6.12-1.1422_FC5 - on my system that is:
2.6.12-1.1485_FC5
2.6.12-1.1483_FC5
2.6.12-1.1482_FC5
2.6.12-1.1455_FC5

How reproducible:
Every time when booting one of those kernels. When booting 1.422_FC5 or older,
it works.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kyrre Ness Sjøbæk 2005-09-11 16:50:40 EDT
I now se the *exact* same problem on another laptop (compaq EVO n600c) running
FC4. On-CD kernel behaves well with ACPI (kernel-2.6.11-1.1369_FC4). Newest
(kernel-2.6.12-1.1447_FC4) i am not able to suspend, as the folder is empty.
Auto fan-control etc. works like a charm (anything "auto" acctually - i could
not say this about FC2 in which i had to manually (by modyfying an init script)
start the fan on boot-time, after which it could not be turned back off. It was
laptop had a reputation for having *bad* Linux-ACPI support then, now it works
like a charm - almost.

Is there something i am missing here? An interface change? Was i suspending the
"wrong" way?

lspci output:
[kyrre@kyrrelaptop ~]$ /sbin/lspci
00:00.0 Host bridge: Intel Corporation 82830 830 Chipset Host Bridge (rev 02)
00:01.0 PCI bridge: Intel Corporation 82830 830 Chipset AGP Bridge (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801CA/CAM USB (Hub #1) (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801CA/CAM USB (Hub #2) (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801CA/CAM USB (Hub #3) (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 41)
00:1f.0 ISA bridge: Intel Corporation 82801CAM ISA Bridge (LPC) (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801CAM IDE U100 (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY
02:03.0 CardBus bridge: Texas Instruments PCI1420
02:03.1 CardBus bridge: Texas Instruments PCI1420
02:04.0 Communication controller: Agere Systems (former Lucent Microelectronics)
LT WinModem (rev 02)
02:08.0 Ethernet controller: Intel Corporation 82801CAM (ICH3) PRO/100 VM (KM)
Ethernet Controller (rev 41)
02:09.0 Multimedia audio controller: ESS Technology ES1988 Allegro-1 (rev 12)
03:00.0 Network controller: Linksys ADMtek ADM8211 802.11b Wireless Interface
(rev 20)
Comment 2 Kyrre Ness Sjøbæk 2005-09-11 16:55:07 EDT
LSPCI from the Dell lattitude c600 (the first mentioned computer):
[kyrre@testpc ~]$ /sbin/lspci
00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge
(rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge
(rev 03)
00:03.0 CardBus bridge: Texas Instruments PCI1420
00:03.1 CardBus bridge: Texas Instruments PCI1420
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)
00:08.0 Multimedia audio controller: ESS Technology ES1983S Maestro-3i PCI Audio
Accelerator (rev 10)
00:10.0 Ethernet controller: 3Com Corporation 3c556 Hurricane CardBus [Cyclone]
(rev 10)
00:10.1 Communication controller: 3Com Corporation Mini PCI 56k Winmodem (rev 10)
01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility M3 AGP 2x
(rev 02)
Comment 3 Philip Balister 2005-09-15 07:46:12 EDT
I'm running a fully updated FC3 and also now have suspend/resume problems. For a
while things worked pretty good, then they stopped working. (DELL 600D/500M)

I did have to change my script to echo mem  > /sys/power/state at some point.

I suspend fine, but the the resume doesn't work anymore.

If the bug is ever changed from new, I'll invest some work trying to pin done
what kernel version worked ....

Philip
Comment 4 Kyrre Ness Sjøbæk 2005-09-15 09:51:30 EDT
I just tested on the compaq - it actually works. Just didn't know about the
interface change. Note that i cannot go back to on-cd kernel, as either my wlan
card (adm8211) or NetworkManager makes the machine "stutter" every 2 second.

"mem" works 100% perfectly, including resume. Wonderfull. "standby" kind of
works - exept it forgets to turn of the LCD before shutting down, making some...
colourfull "effects". It doesn't even respond to "disk".

X11 was open and all, didn't unload any drivers. Got some "strange" ACPI-related
error messages while suspending/resuming, but it did work. I shall take a
picture of the messages and upload it here.

With the C600, "standby" kindof works - exept it also there forgets to blank the
screen. But after printing "PM: Entering standby sleep" and blinking the power
lamp once-per-secound, it also here "forgets" to swithc of the LCD. After
hitting the powerbutton, it shuts down the LCD, brings it back up for a secound
before shutting it down again, waits 10 secounds, and then comming up with LCD
and disk.

"mem" suspends ("PM: entering mem sleep", shudown of LCD, LCD back up for 2
secounds before shutdown together with disk) fine, resume also works perfectly.

"disk" writes out data to swap, completely shutting down the pc. when it comes
back up, i get the BIOS,  grub, and then it reads back from swap. I then get a
message "Debug: sleep function called from invalid context" and then a
traceback. No big suprise, as i know i am supposed to echo something into
somewhere else first...

This was done on kernel 2.6.13-1.1552_FC5.
Comment 5 Thomas Fischer 2005-09-17 04:35:53 EDT
Created attachment 118927 [details]
boot log for kernel 2.6.11
Comment 6 Thomas Fischer 2005-09-17 04:36:58 EDT
Created attachment 118928 [details]
boot log for kernel 2.6.12
Comment 7 Thomas Fischer 2005-09-17 04:37:44 EDT
I have seen the same problem and it seems that ACPI is not working properly in
kernel 2.6.12 because the hooks are not set-up in /proc.

The symptom is that the new kernel is not detecting and correctly setting up the
power mgmt devices/attributes. This means that for example sleep is not enabled.

The boot log messages (that I have attached) show the system correctly detecting
the bios modes but the kernel doesn't create the appropriate /proc/acpi files.

If I go back to kernel 2.6.11-1.1369_FC4, it works ok. I am attaching the boot
logs for both kernels

==================== ACPI Working Correctly under 2.6.11====================
=== /proc/acpi

dr-xr-xr-x    3 root root 0 Sep 14 09:56 ac_adapter
-rw-r--r--    1 root root 0 Sep 14 09:56 alarm
dr-xr-xr-x    4 root root 0 Sep 14 09:56 battery
dr-xr-xr-x    5 root root 0 Sep 14 09:56 button
-r--------    1 root root 0 Sep 14 09:56 dsdt
dr-xr-xr-x    2 root root 0 Sep 14 09:56 embedded_controller
-r--------    1 root root 0 Sep 14 08:26 event
-r--------    1 root root 0 Sep 14 09:56 fadt
dr-xr-xr-x    2 root root 0 Sep 14 09:56 fan
-r--r--r--    1 root root 0 Sep 14 09:56 info
dr-xr-xr-x    3 root root 0 Sep 14 09:56 power_resource
dr-xr-xr-x    3 root root 0 Sep 14 09:56 processor
-rw-r--r--    1 root root 0 Sep 14 09:56 sleep
dr-xr-xr-x    3 root root 0 Sep 14 09:56 thermal_zone
dr-xr-xr-x    3 root root 0 Sep 14 09:56 video
-rw-r--r--    1 root root 0 Sep 14 09:56 wakeup


==================== ACPI not Working under 2.6.12====================
=== /proc/acpi
dr-xr-xr-x    3 root root 0 Sep 17 10:31 ac_adapter
-rw-r--r--    1 root root 0 Sep 17 10:31 alarm
dr-xr-xr-x    4 root root 0 Sep 17 10:31 battery
-r--------    1 root root 0 Sep 17 10:31 dsdt
dr-xr-xr-x    2 root root 0 Sep 17 10:31 embedded_controller
-r--------    1 root root 0 Sep 17 10:15 event
-r--------    1 root root 0 Sep 17 10:31 fadt
dr-xr-xr-x    2 root root 0 Sep 17 10:31 fan
-r--r--r--    1 root root 0 Sep 17 10:31 info
dr-xr-xr-x    3 root root 0 Sep 17 10:31 power_resource
dr-xr-xr-x    3 root root 0 Sep 17 10:31 processor
dr-xr-xr-x    3 root root 0 Sep 17 10:31 thermal_zone
dr-xr-xr-x    3 root root 0 Sep 17 10:31 video
-rw-r--r--    1 root root 0 Sep 17 10:31 wakeup
Comment 8 Thomas Fischer 2005-09-19 03:34:10 EDT
Created attachment 118960 [details]
Kernel 2.6.11 boot message log
Comment 9 Thomas Fischer 2005-09-23 06:16:08 EDT
I just upgraded to kernel version 2.6.12-1.1456_FC4 and the problem is still 
present. The sleep attribute is not being taken into account
Comment 10 Dave Jones 2005-09-28 05:14:53 EDT
/proc/acpi/sleep support has been deprecated for a while, and recently got
removed.  In its place, the way to do suspend, is using /sys/power/state
Comment 11 Kyrre Ness Sjøbæk 2005-09-28 06:34:18 EDT
Well, there is still a problem remaining: Where have fan controll, CPU temp
readout etc. gone - all things where possible trough the /proc/acpi interface

Note You need to log in before you can comment on or make changes to this bug.