Bug 166100 - %pre scripts defined in %include files don't get run
%pre scripts defined in %include files don't get run
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks: 170445
  Show dependency treegraph
 
Reported: 2005-08-16 18:16 EDT by David Lehman
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 16:26:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2005-08-16 18:16:06 EDT
Description of problem:
If a supplemental kickstart config is specified via %include contains %pre
scripts they will not be run.

Version-Release number of selected component (if applicable):
anaconda-9.1.6.8-1.RHEL

How reproducible:
Always

Steps to Reproduce:
1. create a ks.cfg that uses %include to append ks-two.cfg
2. define a %pre script in the to-be-included ks-two.cfg
3. run it (ks=ks.cfg)
  
Actual results:
Everything in ks-two.cfg seems to be working except the %pre

Expected results:
Everything in ks-two.cfg should work.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.