Bug 1661005 (CVE-2018-12122) - CVE-2018-12122 nodejs: Slowloris HTTP Denial of Service
Summary: CVE-2018-12122 nodejs: Slowloris HTTP Denial of Service
Alias: CVE-2018-12122
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
Depends On: 1661006 1661007 1668704 1668705 1668706 1720059 1720060 1720061 1720062
Blocks: 1661014
TreeView+ depends on / blocked
Reported: 2018-12-19 19:49 UTC by Laura Pardo
Modified: 2021-02-16 22:38 UTC (History)
16 users (show)

Fixed In Version: nodejs 6.15.1, nodejs 8.14.0, nodejs 10.14.0, nodejs 11.3.0
Doc Type: If docs needed, set a value
Doc Text:
It was found that Node.js HTTP server was vulnerable to a Slowloris type attack. An attacker could make long lived connections by sending bytes very slowly to the server, saturating its resource and possibly resulting in a denial of service.
Clone Of:
Last Closed: 2019-07-22 15:07:00 UTC

Attachments (Terms of Use)

System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1844 0 None None None 2019-07-24 14:56:05 UTC
Red Hat Product Errata RHBA-2019:1869 0 None None None 2019-07-26 18:08:49 UTC
Red Hat Product Errata RHSA-2019:1821 0 None None None 2019-07-22 13:37:54 UTC

Description Laura Pardo 2018-12-19 19:49:11 UTC
A flaw was found in Node.js versions before 6.15.0, 8.14.0, 10.14.0 and 11.3.0. A Slowloris HTTP Denial of Service. An attacker can cause a Denial of Service (DoS) by sending headers very slowly keeping HTTP or HTTPS connections and associated resources alive for a long period of time. 


Comment 1 Laura Pardo 2018-12-19 19:49:26 UTC
Created nodejs tracking bugs for this issue:

Affects: epel-all [bug 1661007]
Affects: fedora-all [bug 1661006]

Comment 2 Cedric Buissart 2019-01-15 17:05:33 UTC
Quick correction on nodejs 6 : the commit 5d9005c35 is also required. The fixed version is actually 6.15.1

Comment 8 Sam Fowler 2019-06-13 05:16:17 UTC

The nodejs RPMs shipped in Red Hat OpenShift Container Platform (OCP) versions 3.6 through 3.10 are vulnerable to this flaw because they contain the affected code. Later versions of OCP used nodejs RPMs delivered from Red Hat Software Collections and Red Hat Enterprise Linux channels.

Comment 11 Cedric Buissart 2019-06-19 09:20:12 UTC

The use of a Load Balancer or a Reverse Proxy will increase the difficulty of the attack.

Comment 12 errata-xmlrpc 2019-07-22 13:37:53 UTC
This issue has been addressed in the following products:

  Red Hat Software Collections for Red Hat Enterprise Linux 7
  Red Hat Software Collections for Red Hat Enterprise Linux 7.4 EUS
  Red Hat Software Collections for Red Hat Enterprise Linux 7.5 EUS
  Red Hat Software Collections for Red Hat Enterprise Linux 7.6 EUS

Via RHSA-2019:1821 https://access.redhat.com/errata/RHSA-2019:1821

Comment 13 Product Security DevOps Team 2019-07-22 15:07:00 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):


Comment 14 Cedric Buissart 2020-02-17 13:03:03 UTC
In rh-nodejs10-nodejs, this was fixed via the rebase from RHSA-2019:2939 : https://access.redhat.com/errata/RHSA-2019:2939

Note You need to log in before you can comment on or make changes to this bug.