Bug 166102 - OOo hangs on start up
OOo hangs on start up
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-16 18:34 EDT by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: openoffice.org-1.9.124-3.2.0.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 00:35:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2005-08-16 18:34:31 EDT
Description of problem:
Starting any OOo application up from the command line or gnome short cuts causes
a hang during the boot up "screen" at about 50% completetion

Version-Release number of selected component (if applicable):
1.9.124

How reproducible:
Always

Steps to Reproduce:
1. Upgrade and start any OOo application
2.
3.
  
Actual results:
Hangs at 50% during start up

Expected results:
Should start as usual

Additional info:
The problem lies in ~/.openoffice.org2.0 somewhere. If you hose the existing
one, everything starts happily.
Comment 1 Ulrich Drepper 2005-08-17 02:54:31 EDT
I see the same.  On i386 and (using x86 binaries) x86-64.

Attaching to the process with strace shows this:

lseek(92, 14060, SEEK_SET)              = 14060
lseek(92, 0, SEEK_CUR)                  = 14060
read(92, "", 1024)                      = 0
lseek(92, 14060, SEEK_SET)              = 14060
lseek(92, 0, SEEK_CUR)                  = 14060
read(92, "", 1024)                      = 0

Over and over again.  That file descriptor is opened for

~/.openoffice.org2.0/user/psprint/pspfontcache
Comment 2 Paul F. Johnson 2005-08-17 03:19:50 EDT
Purely out of interest, why does hosing the existing .openoffice2.0 and
regenerating it stop this problem?
Comment 3 Caolan McNamara 2005-08-17 04:18:33 EDT
because one of the patches changed the pspfontcache format, then another patch
got merged into upstream making this patch look like it was already applied, but
only part of it was applied, grr. So pspfontcache format writtern by previous
OOo's didn't match the current ones expectations.

Should be fixable, but something to very much keep an eye on port integration of
upstream workspace vcl39

1.9.124-2
Comment 4 Alexandre Oliva 2005-08-19 00:35:29 EDT
Confirmed fixed, thanks!

Note You need to log in before you can comment on or make changes to this bug.