Bug 1661041 - /etc/rhsm/rhsm.conf is being incorrectly edited during registration
Summary: /etc/rhsm/rhsm.conf is being incorrectly edited during registration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: katello-agent
Version: 6.4.0
Hardware: x86_64
OS: Linux
medium
high vote
Target Milestone: 6.4.2
Assignee: satellite6-bugs
QA Contact: Jan Hutař
URL:
Whiteboard:
: 1687009 (view as bug list)
Depends On: 1651189
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-19 22:37 UTC by Mike McCune
Modified: 2019-10-30 19:28 UTC (History)
6 users (show)

Fixed In Version: katello-installer-base-3.7.0.13-1
Doc Type: Bug Fix
Doc Text:
Cause: Typo in the script in a if branch executed only under some circumstances. Consequence: Invalid /usr/bin/katello-rhsm-consumer generates invalid /etc/rhsm/rhsm.conf Fix: Script was fixed Result: To fix this, besides applying update, you also need to regenerate bootstrap rpm: https://access.redhat.com/solutions/3103341
Clone Of: 1651189
Environment:
Last Closed: 2019-02-13 19:33:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 25512 0 Normal Closed /etc/rhsm/rhsm.conf is being incorrectly edited during registration 2020-07-15 17:04:47 UTC
Red Hat Knowledge Base (Solution) 4128341 0 Troubleshoot None Installation of 'katello-ca-consumer' fails with 'warning: %post(katello-ca-consumer-satellite.example.com-1.0-1.noarch)... 2019-05-10 13:15:47 UTC
Red Hat Product Errata RHBA-2019:0346 0 None None None 2019-02-13 19:33:03 UTC

Comment 3 Evgeni Golov 2019-01-07 18:15:52 UTC
I *think* this is fixed by https://projects.theforeman.org/issues/25512, but for some reason the BZ→Redmine link was lost during clone wars.

Comment 4 Bryan Kearney 2019-01-07 21:10:47 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/25512 has been resolved.

Comment 7 errata-xmlrpc 2019-02-13 19:33:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0346

Comment 8 Brad Buckingham 2019-03-25 16:23:34 UTC
*** Bug 1687009 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.