Bug 1661076 - Support node selector in metrics-server playbook
Summary: Support node selector in metrics-server playbook
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.11.z
Assignee: Frederic Branczyk
QA Contact: Weinan Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-20 03:49 UTC by Takayoshi Kimura
Modified: 2019-06-26 09:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-26 09:07:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1661073 low CLOSED [DOCS] Add metrics-server document 2020-10-14 00:28:05 UTC
Red Hat Product Errata RHBA-2019:1605 None None None 2019-06-26 09:08:02 UTC

Internal Links: 1661073

Description Takayoshi Kimura 2018-12-20 03:49:21 UTC
Description of problem:

All non-app OpenShift components install come with node selector support but it seems that the metrics-server install is missing the node selector support.

Version-Release number of selected component (if applicable):

openshift v3.11.16

How reproducible:

Always

Steps to Reproduce:
1.
2.
3.

Actual results:

Users cannot specify node selector for metrics-server in Ansible, metrics-server goes to default node selector role=compute and consume app node resource.

Expected results:

Users can specify node selector for metrics-server in Ansible

Additional info:

Should metrics-server be installed by default?

Previously hawkular stack was optional but now we install Prometheus by default, so I feel it's better to install metrics-server by default along with Prometheus to align the changes.

Comment 1 Frederic Branczyk 2019-02-04 15:51:11 UTC
We intentionally didn't deploy metrics-server by default as in 3.11 we wanted to give users the choice. Starting with 4.0 we are shipping the prometheus-adapter by default (which offers the same API as the metrics-server, but backed by Prometheus).

Comment 3 Brian Jarvis 2019-05-03 12:47:46 UTC
The installer should not deploy metrics-server by default, but it should allow a user to specify a node selector for where the metrics-server pods should run.  

Many users separate worker nodes based on security rules, not allowing the user to specify where metrics-server pods run during the install forces users to manually modify the deployment.  This is a practice we should not be encouraging.

Comment 4 Frederic Branczyk 2019-05-03 15:56:25 UTC
Sorry I agree, this shouldn't have been closed. I think this is reasonable to add.

Comment 5 Frederic Branczyk 2019-05-10 15:07:38 UTC
Opened https://github.com/openshift/openshift-ansible/pull/11599 to fix this.

Comment 6 Frederic Branczyk 2019-05-10 17:59:38 UTC
PR merged

Comment 10 errata-xmlrpc 2019-06-26 09:07:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1605


Note You need to log in before you can comment on or make changes to this bug.