Bug 166108 - ypbind disappears if ypserv crashes
ypbind disappears if ypserv crashes
Status: CLOSED DUPLICATE of bug 167061
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ypbind (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-16 19:16 EDT by Konstantin Olchanski
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-28 12:41:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konstantin Olchanski 2005-08-16 19:16:17 EDT
Description of problem:

If ypserv crashes, ypbind processes silently disappear instead of patiently
waiting for ypserv to come back.

Version-Release number of selected component (if applicable):

ypbind-1.17.2-3.i386

How reproducible:

Quite often, but not always. This time, in a cluster of about 10 machines, only
1 ypbind was missing. All the others survived and reconnected to ypserv when it
was restarted. ypbind on the NIS server machine seems to never disappear.

Steps to Reproduce:
Take an NIS server with a few NIS clients. Kill ypserv (the infamous "svc_run: -
poll failed: No child processes" problem in RHL9). Wait for, say, 12 hours,
restart ypserv.
  
Actual results:

On some clients ypbinds are gone and have to be restarted manually.

Expected results:

All ypbinds should survive the NIS outage and reconnect to ypserv when it
becomes available.

Additional info:

We see the same problem in Fedora 3. RHL9 was fine. No data for Fedora 1,2 or 4.

K.O.
Comment 1 Konstantin Olchanski 2005-08-16 19:45:30 EDT
Forgot to say what I see in the system log: "ypbind[3317]: broadcast: RPC: Timed
out." while ypserv is down. Then these messages stop and ypbind is not running. K.O.
Comment 2 Chris Feist 2005-09-06 17:22:37 EDT
I believe this is the same problem that caused bz #167061.

Please try the ypbind-1.17.2-8 rpm and let me know if it solves your problem.

The ypbind-1.17.2-8 rpm can be found here: http://people.redhat.com/cfeist/ypbind/
Comment 4 Chris Feist 2007-02-28 12:41:28 EST
No response to NEEDINFO since 9/6/06, closing as a dup.

*** This bug has been marked as a duplicate of 167061 ***

Note You need to log in before you can comment on or make changes to this bug.