Bug 166112 - KDE "switch user" does not work
KDE "switch user" does not work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
http://www.kleineisel.de/ralf/switchu...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-16 20:06 EDT by Ralf Kleineisel
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-17 09:34:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Kleineisel 2005-08-16 20:06:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.11) Gecko/20050729

Description of problem:
The KDE "Switch user" menu is empty.

According to the KDE documentation (http://docs.kde.org/development/en/kdebase/userguide/switching-sessions.html) it should contain two entries to lock the current session and start a new one or to just start a new one.

On my FC4 box this menu is empty except for the session that is currently running. There seems to be no way to get an additional KDE session for another user.

Version-Release number of selected component (if applicable):
kdebase-3.4.2-0.fc4.1

How reproducible:
Always

Steps to Reproduce:
1. Right click on the desktop background
2. From the menu choose "Switch User"
3.
  

Actual Results:  Menu pops up but misses entries.

Expected Results:  Entries should be there.

Additional info:
Comment 1 Ngo Than 2005-08-17 09:34:19 EDT
it's now fixed in KDE-3.4.2-2 in rawhide. for quick fix, you should   
add the followings lines in section [General] from /etc/X11/xdm/kdmrc  
   
# This option exists solely for the purpose of a clean automatic upgrade.   
# Do not even think about changing it!   
ConfigVersion=2.3   
# List of permanent displays. Displays with a hostname are foreign. A display   
# class may be specified separated by an underscore.   
# Default is ":0"   
StaticServers=:0   
# List of on-demand displays. See StaticServers for syntax.   
# Default is ""   
ReserveServers=:1,:2,:3   
# VTs to allocate to X-servers. A negative number means that the VT will be   
# used only if it is free. If all VTs in this list are used up, the next free   
# one greater than the last one in this list will be allocated.   
# Default is ""   
# ServerVTs=-7   
# TTYs (without /dev/) to monitor for activity while in console mode.   
# Default is ""   
ConsoleTTYs=tty1,tty2,tty3,tty4,tty5,tty6   
 
 
thanks for your report. 

Note You need to log in before you can comment on or make changes to this bug.