Bug 166114 - Slow
Summary: Slow
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-17 00:12 UTC by Bernie Innocenti
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-17 03:35:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bernie Innocenti 2005-08-17 00:12:27 UTC
Description of problem:

The kernel-devel RPM package takes forever to install
because the postinstall scriptlet contains this line:

 /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f
$f ; done

It could be improved by using xargs.

Comment 1 Dave Jones 2005-08-17 03:35:01 UTC
This is an IO bound operation, so I'm very doubtful it'll be faster.
The only thing that will speed this up notably is to not have as many kernels
installed at the same time.



Note You need to log in before you can comment on or make changes to this bug.