Bug 1661196 - [OSP13] ovaException: Unsupported VIF type unbound convert '_nova_to_osvif_vif_unbound'
Summary: [OSP13] ovaException: Unsupported VIF type unbound convert '_nova_to_osvif_vi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: z6
: 13.0 (Queens)
Assignee: Stephen Finucane
QA Contact: nova-maint
URL:
Whiteboard:
: 1704497 (view as bug list)
Depends On: 1661193
Blocks: 1578028
TreeView+ depends on / blocked
 
Reported: 2018-12-20 11:34 UTC by Stephen Finucane
Modified: 2019-09-09 17:16 UTC (History)
9 users (show)

Fixed In Version: openstack-nova-17.0.9-6.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1661193
Environment:
Last Closed: 2019-04-30 17:13:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1809136 None None None 2018-12-20 11:34:40 UTC
OpenStack gerrit 626550 'None' MERGED Handle unbound vif plug errors on compute restart 2020-02-03 23:10:57 UTC
Red Hat Product Errata RHBA-2019:0924 None None None 2019-04-30 17:14:13 UTC

Comment 7 Joe H. Rahme 2019-04-25 09:51:27 UTC
1. Create a server with a port on a private network

	(overcloud) [stack@undercloud-0 ~]$ openstack server show ${SERVER}
	+-------------------------------------+---------------------------------------------------------------------+
	| Field                               | Value                                                               |
	+-------------------------------------+---------------------------------------------------------------------+
	| OS-DCF:diskConfig                   | MANUAL                                                              |
	| OS-EXT-AZ:availability_zone         | nova                                                                |
	| OS-EXT-SRV-ATTR:host                | compute-1.localdomain                                               |
	| OS-EXT-SRV-ATTR:hypervisor_hostname | compute-1.localdomain                                               |
	| OS-EXT-SRV-ATTR:instance_name       | instance-00000005                                                   |
	| OS-EXT-STS:power_state              | Running                                                             |
	| OS-EXT-STS:task_state               | None                                                                |
	| OS-EXT-STS:vm_state                 | active                                                              |
	| OS-SRV-USG:launched_at              | 2019-04-25T09:37:03.000000                                          |
	| OS-SRV-USG:terminated_at            | None                                                                |
	| accessIPv4                          |                                                                     |
	| accessIPv6                          |                                                                     |
	| addresses                           | private=192.168.200.26                                              |
	| config_drive                        |                                                                     |
	| created                             | 2019-04-25T09:36:52Z                                                |
	| flavor                              | m1.nano (84b564bb-51cf-41fc-adea-15b516dcd527)                      |
	| hostId                              | 1ff3d27b587c01eff3a0d6a53e67207207ded52654e8597517c5ef26            |
	| id                                  | 4be4c2a9-d947-466e-b8dd-2b47ce97d265                                |
	| image                               | cirros-0.3.5-x86_64-disk.img (f272f221-fa36-4e18-800d-1bbcb9eb1bb2) |
	| key_name                            | None                                                                |
	| name                                | repro-bug                                                           |
	| progress                            | 0                                                                   |
	| project_id                          | be47c8cfb80446fd85e58f9ef060db0f                                    |
	| properties                          |                                                                     |
	| security_groups                     | name='default'                                                      |
	| status                              | ACTIVE                                                              |
	| updated                             | 2019-04-25T09:37:04Z                                                |
	| user_id                             | 17be1bcfab9c438f99201442cd73f6e2                                    |
	| volumes_attached                    |                                                                     |
	+-------------------------------------+---------------------------------------------------------------------+


2. Mark this port as unbound

    (overcloud) [stack@undercloud-0 ~]$ curl -X PUT -H "X-Auth-Token:${TEMP_TOKEN}" -d '{ "port":{"binding:host_id":"" }}' "${NEUTRON_ENDPOINT}/v2.0/ports/${PORT_ID}" | python -m json.tool
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    100   923  100   890  100    33    630     23  0:00:01  0:00:01 --:--:--   630
    {
        "port": {
            "admin_state_up": true,
            "allowed_address_pairs": [],
            "binding:host_id": "",
            "binding:profile": {},
            "binding:vif_details": {},
            "binding:vif_type": "unbound",
            "binding:vnic_type": "normal",
            "created_at": "2019-04-25T09:36:57Z",
            "description": "",
            "device_id": "4be4c2a9-d947-466e-b8dd-2b47ce97d265",
            "device_owner": "compute:nova",
            "extra_dhcp_opts": [],
            "fixed_ips": [
                {
                    "ip_address": "192.168.200.26",
                    "subnet_id": "005085ac-e6e4-4028-8ea5-f7d59e306dca"
                }
            ],
            "id": "3e1005d5-d8c4-43a1-ad1a-2518fb8c6b18",
            "ip_allocation": "immediate",
            "mac_address": "fa:16:3e:e3:a6:73",
            "name": "",
            "network_id": "4861f13b-92b0-414a-8e63-25fb1929b970",
            "port_security_enabled": true,
            "project_id": "be47c8cfb80446fd85e58f9ef060db0f",
            "qos_policy_id": null,
            "revision_number": 5,
            "security_groups": [
                "521130bc-345c-47f6-ad2f-cb2a61201662"
            ],
            "status": "DOWN",
            "tags": [],
            "tenant_id": "be47c8cfb80446fd85e58f9ef060db0f",
            "updated_at": "2019-04-25T09:37:02Z"
        }
    }

3. Restart the compute container

	[heat-admin@compute-1 ~]$ sudo docker restart nova_compute
	nova_compute

Comment 9 errata-xmlrpc 2019-04-30 17:13:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0924

Comment 10 Nate Johnston 2019-08-23 14:15:20 UTC
*** Bug 1704497 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.