Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1661337 - RHEL 8 - man 5 nm-settings-ifcfg-rh table too wide for terminal display
Summary: RHEL 8 - man 5 nm-settings-ifcfg-rh table too wide for terminal display
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: man-db
Version: 8.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 8.0
Assignee: Nikola Forró
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
: 1661340 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-20 21:30 UTC by Sterling Alexander
Modified: 2021-02-01 07:31 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-01 07:31:24 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
man page at 120 columns (57.01 KB, image/png)
2018-12-20 21:30 UTC, Sterling Alexander
no flags Details
man page at 154 columns (77.86 KB, image/png)
2018-12-20 21:35 UTC, Sterling Alexander
no flags Details

Description Sterling Alexander 2018-12-20 21:30:28 UTC
Created attachment 1515992 [details]
man page at 120 columns

Description of problem:  This man page has issues with the table.  The table will display correctly if the terminal column value is set to 154.  Additionally, the following errors are seen:

tbl:<standard input>:354: no format
tbl:<standard input>:354: giving up on this table
<standard input>:412: warning [p 3, 9.2i, div `3tbd1,1', 0.0i]: can't break line
<standard input>:418: warning [p 3, 9.2i, div `3tbd1,3', 0.7i]: can't break line
<standard input>:436: warning [p 3, 9.2i, div `3tbd3,1', 0.0i]: can't break line
<standard input>:451: warning [p 3, 9.2i, div `3tbd4,3', 0.8i]: can't break line
<standard input>:487: warning [p 3, 9.2i, div `3tbd8,1', 0.0i]: can't break line
<standard input>:493: warning [p 3, 9.2i, div `3tbd8,3', 0.7i]: can't break line
<standard input>:498: warning [p 3, 9.2i, div `3tbd9,1', 0.0i]: can't break line
<standard input>:529: warning [p 3, 9.2i, div `3tbd12,1', 0.0i]: can't break line
<standard input>:538: warning [p 3, 9.2i, div `3tbd13,0', 0.0i]: can't break line
<standard input>:559: warning [p 3, 9.2i, div `3tbd14,3', 0.5i]: can't break line
<standard input>:601: warning [p 3, 9.2i, div `3tbd18,0', 0.0i]: can't break line
<standard input>:603: warning [p 3, 9.2i, div `3tbd18,1', 0.0i]: can't break line
<standard input>:610: warning [p 3, 9.2i, div `3tbd19,0', 0.0i]: can't break line
<standard input>:612: warning [p 3, 9.2i, div `3tbd19,1', 0.0i]: can't break line
<standard input>:627: warning [p 3, 9.2i, div `3tbd20,3', 0.5i]: can't break line
<standard input>:706: warning [p 3, 9.2i, div `3tbd29,0', 0.0i]: can't break line
<standard input>:715: warning [p 3, 9.2i, div `3tbd30,0', 0.0i]: can't break line
<standard input>:717: warning [p 3, 9.2i, div `3tbd30,1', 0.0i]: can't break line
warning: file `<standard input>', around line 371:
  table wider than line width

[...snip...]

Version-Release number of selected component (if applicable):  RHEL 8


How reproducible:  100% of the time, every time


Steps to Reproduce:
1.  open the man page

Actual results:  Table is garbled, errors thrown while opening man page

Comment 1 Sterling Alexander 2018-12-20 21:35:07 UTC
Created attachment 1515993 [details]
man page at 154 columns

Comment 2 Nikola Forró 2018-12-21 15:07:08 UTC
This man page is part of NetworkManager, however, the "problem" is in the pager, which is less by default.
less wraps lines longer than screen width by default, but it can be configured to truncate them instead.
Try:

MANPAGER="less -S" man 5 nm-settings-ifcfg-rh

You can also set it permanently in /etc/man_db.conf by adding:

DEFINE  pager   less -S

Comment 3 Nikola Forró 2018-12-21 15:08:02 UTC
*** Bug 1661340 has been marked as a duplicate of this bug. ***

Comment 6 RHEL Program Management 2021-02-01 07:31:24 UTC
After evaluating this issue, there are no plans to address it further or fix it in an upcoming release.  Therefore, it is being closed.  If plans change such that this issue will be fixed in an upcoming release, then the bug can be reopened.


Note You need to log in before you can comment on or make changes to this bug.