Bug 1661374 - Fonts and Tabs chopped in 3rd party application
Summary: Fonts and Tabs chopped in 3rd party application
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: gtk3
Version: 8.0
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: rc
: 8.0
Assignee: Benjamin Otte
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-21 03:47 UTC by Ian Laurie
Modified: 2020-10-09 17:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-06 21:13:52 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Picture showing corrupted fonts and tabs (102.18 KB, image/jpeg)
2018-12-21 03:47 UTC, Ian Laurie
no flags Details

Description Ian Laurie 2018-12-21 03:47:33 UTC
Created attachment 1516026 [details]
Picture showing corrupted fonts and tabs

Description of problem:
I installed Netbeans 8.2 in RHEL 8 beta and noticed that the GTK+ theme didn't work as expected.  Tabs and fonts on docked windows (left and bottom) were sized incorrectly, and the fonts overall were not quite right.  Only the GTK+ theme is broken, all the default themes work fine.  See attached pic.

Version-Release number of selected component (if applicable):
gtk3-3.22.30-1.el8.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install java & Netbeans 8.2 
2. Select the GTK+ theme
3.

Actual results:
Tabs and fonts broken on docked windows using the GTK+ theme.

Expected results:
GTK+ theme should work like the other themes.

Additional info:
The GTK+ theme works fine on CentOS 7.5 & 7.6, and works on Fedora 28 & 29.

I marked this as low severity because right now it may only be a problem if you install 3rd party apps.  However I can see this becoming a bigger issue when EPEL becomes available for RHEL 8 and people start installing IDEs and so on.

Comment 1 Ian Laurie 2019-02-18 03:33:48 UTC
I replaced Oracle's NetBeans 8.2 with the latest Apache "incubating" NetBeans 10.0 and I am no longer seeing this issue with the GTK+ theme.

Comment 3 Matthias Clasen 2020-10-06 21:13:52 UTC
netbeans is not a GTK application. There is very little GTK can do to address the problem that occurs when 3rd party applications are using parts of GTK theme information for their own rendering.


Note You need to log in before you can comment on or make changes to this bug.