Bug 1661414 - No message display when set service level by subscription manager
Summary: No message display when set service level by subscription manager
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: subscription-manager
Version: 8.0
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: rc
: 8.1
Assignee: ojanus
QA Contact: Red Hat subscription-manager QE Team
Ioanna Gkioka
URL:
Whiteboard:
Depends On: 1632283 1682763
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-21 07:36 UTC by yanpliu
Modified: 2019-07-26 17:54 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
.No message is printed for the successful setting and unsetting of `service-level` When the *candlepin* service does not have a 'syspurpose' functionality, subscription manager uses a different code path to set the `service-level` argument. This code path does not print the result of the operation. As a consequence, no message is displayed when the service level is set by subscription manager. This is especially problematic when the `service-level` set has a typo or is not truly available.
Clone Of:
Environment:
Last Closed: 2019-07-26 17:54:46 UTC
Type: Bug


Attachments (Terms of Use)
rhsm.log (21.26 KB, text/plain)
2019-02-12 07:36 UTC, qianzhan
no flags Details


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 2020 None None None 2019-01-31 08:27:30 UTC

Description yanpliu 2018-12-21 07:36:24 UTC
Description of problem:
No message display when set service level by subscription manager.
When set service level using valid service-level such as "Self-Support", message "Service level set to: Self-Support" does not display.There is no message.
When set service level using invalid service-level such as "test", there is no message display.



Version-Release number of selected component (if applicable):
python3-subscription-manager-rhsm-1.23.8-11.el8.x86_64
subscription-manager-rhsm-certificates-1.23.8-11.el8.x86_64
dnf-plugin-subscription-manager-1.23.8-11.el8.x86_64
subscription-manager-1.23.8-11.el8.x86_64
katello-3.7.0-8.el7sat.noarch
tfm-rubygem-katello-3.7.0.42-2.el7sat.noarch
candlepin-2.4.8-1.el7.noarch

How reproducible:


Steps to Reproduce:

1.Register RHEL-8.0-20181218.0 against Satellite6.4
# subscription-manager register --username=admin --password=xxxx
Registering to: ibm-x3650-01.ovirt.rhts.eng.bos.redhat.com:443/rhsm
The system has been registered with ID: 4303547b-f5f0-4a17-bfd7-beca1626fc55
The registered system name is: cloud-qe-16-vm-06.idmqe.lab.eng.bos.redhat.com

2.set service-level as Self-Support
#  subscription-manager service-level --set=Self-Support

There is no message display.
"Self-Support", message "Service level set to: Self-Support" does not display

3.# syspurpose show
{}
syspurpose service level can not set.

# subscription-manager service-level --show
Current service level: Self-Support


4.set service-level as invalid service level "test"
# subscription-manager service-level --set=test
There is no message display.
Alert message for not supporting invalid service level does not display.
 

# subscription-manager service-level --show
Current service level: Self-Support


Actual results:
Step2 message "Service level set to: Self-Support" does not display
Step3 can not show service level by syspurpose
Step4 There is no alert message for not supporting invalid service level display.

Expected results:
Step2 message "Service level set to: Self-Support" should display
Step3 should show service level by syspurpose
Step4 Alert message for not supporting invalid service level should display.

Additional info:

Comment 1 Kevin Howell 2019-01-14 15:38:31 UTC
Can you please retest with the latest build?

Comment 2 yanpliu 2019-01-17 05:20:33 UTC
I have verified in the latest build : RHEL-8.0-20190116.n.0 BaseOS x86_64 

python3-subscription-manager-rhsm-1.23.8-14.el8.x86_64
subscription-manager-rhsm-certificates-1.23.8-14.el8.x86_64
dnf-plugin-subscription-manager-1.23.8-14.el8.x86_64
subscription-manager-1.23.8-14.el8.x86_64

katello-3.7.0-8.el7sat.noarch
tfm-rubygem-katello-3.7.0.42-2.el7sat.noarch
candlepin-2.4.8-1.el7.noarch

This issue still can reproduce.


[root@ibm-x3650m4-01-vm-15 ~]# subscription-manager register
Registering to: hp-nehalem-02.rhts.eng.bos.redhat.com:443/rhsm
Username: admin
Password: 
The system has been registered with ID: 6c02c6f3-e249-4a02-9e8b-723d96b82c8f
The registered system name is: ibm-x3650m4-01-vm-15.lab.eng.bos.redhat.com
[root@ibm-x3650m4-01-vm-15 ~]# subscription-manager service-level --set=Self-Support
[root@ibm-x3650m4-01-vm-15 ~]# syspurpose show
{}
Unable to send system purpose to subscription management server
[root@ibm-x3650m4-01-vm-15 ~]# subscription-manager service-level --show
Current service level: Self-Support
[root@ibm-x3650m4-01-vm-15 ~]#  subscription-manager service-level --set=test
[root@ibm-x3650m4-01-vm-15 ~]# subscription-manager service-level --show
Current service level: Self-Support

Comment 7 qianzhan 2019-02-12 07:35:57 UTC
Verification on RHEL-8.0.0-20190129.1 against Satellite6.4.1:
dnf-plugin-subscription-manager-1.23.8-14.el8.x86_64
python3-subscription-manager-rhsm-1.23.8-14.el8.x86_64
subscription-manager-1.23.8-14.el8.x86_64
subscription-manager-rhsm-certificates-1.23.8-14.el8.x86_64
candlepin-2.4.8-1.el7.noarch
tfm-rubygem-katello-3.7.0.42-2.el7sat.noarch


[root@ent-01-vm-01 ~]# subscription-manager register
Registering to: ent-01-vm-02.lab.eng.nay.redhat.com:443/rhsm
Username: admin
Password: 
The system has been registered with ID: 760847ff-f45d-4df9-a1a2-c5fc8853998e
The registered system name is: ent-01-vm-01.lab.eng.nay.redhat.com
[root@ent-01-vm-01 ~]# syspurpose show
{}
Unable to send system purpose to subscription management server
[root@ent-01-vm-01 ~]# 
[root@ent-01-vm-01 ~]# 
[root@ent-01-vm-01 ~]# subscription-manager service-level --set=Self-Support
[root@ent-01-vm-01 ~]# 
[root@ent-01-vm-01 ~]# 
[root@ent-01-vm-01 ~]# syspurpose show
{}
Unable to send system purpose to subscription management server
[root@ent-01-vm-01 ~]# 
[root@ent-01-vm-01 ~]# 
[root@ent-01-vm-01 ~]# subscription-manager service-level --set=test
[root@ent-01-vm-01 ~]# 
[root@ent-01-vm-01 ~]# syspurpose show
{}
Unable to send system purpose to subscription management server

Failed to verify this bug, please refer attachment 'rhsm.log'

Comment 8 qianzhan 2019-02-12 07:36:16 UTC
Created attachment 1533928 [details]
rhsm.log

Comment 11 Chris Snyder 2019-02-26 16:31:23 UTC
This appears to have been patched in subscription-manager-1.23.8-15.

Please retest with that version (or newer).

Comment 12 qianzhan 2019-03-01 06:06:40 UTC
Verification on RHEL-8.0.0-20190228.1 against Satellite6.4.2:

subscription-manager-1.23.8-33.el8.x86_64
dnf-plugin-subscription-manager-1.23.8-33.el8.x86_64
subscription-manager-cockpit-1.23.8-33.el8.noarch
python3-subscription-manager-rhsm-1.23.8-33.el8.x86_64
subscription-manager-rhsm-certificates-1.23.8-33.el8.x86_64
tfm-rubygem-katello-3.7.0.46-1.el7sat.noarch
katello-3.7.0-8.el7sat.noarch
candlepin-2.4.8-1.el7.noarch

1. Register the system against Sat6.4:

[root@kvm-02-guest23 ~]# subscription-manager register
Registering to: ent-01-vm-01.lab.eng.nay.redhat.com:443/rhsm
Username: admin
Password: 
The system has been registered with ID: 74bfb27f-5181-48cf-9bd0-237a2000f4d5
The registered system name is: kvm-02-guest23.rhts.eng.bos.redhat.com

[root@kvm-02-guest23 ~]# syspurpose show <==== VERIFIED: Satellite6.4 does not support system purpose, so the output here is acceptable.
{}
Unable to send system purpose to subscription management server

[root@kvm-02-guest23 ~]# subscription-manager service-level --list
+-------------------------------------------+
               Available Service Levels
+-------------------------------------------+
Basic
Premium
Self-Support
Standard

2. Set a valid service level:

[root@kvm-02-guest23 ~]# subscription-manager service-level --set=Premium
Service level set to: "Premium".        <==== VERIFIED: setting a valid SLA successfully get an accurate notice.
[root@kvm-02-guest23 ~]# subscription-manager service-level --show
Current service level: Premium
[root@kvm-02-guest23 ~]# syspurpose show
{}
Unable to send system purpose to subscription management server


3. Set an invalid service level:
[root@kvm-02-guest23 ~]# subscription-manager service-level --set=test
Service level set to: "test".    <==== FAILED: the message shows invalid SLA is set successfully.
[root@kvm-02-guest23 ~]# echo $?
0
[root@kvm-02-guest23 ~]# subscription-manager service-level --show
Current service level: Premium   <==== FAILED: actually the invalid SLA is not set, and the setting keeps the same with step 2(a valid SLA)
[root@kvm-02-guest23 ~]# syspurpose show
{}
Unable to send system purpose to subscription management server


===================================
According to step 3, when setting an invalid service level, 'subscription-manager service-level --set' returns a inaccurate notice, because the invalid SLA is not set actually. So move the bug to NEW from ON_QA.

Comment 13 John Sefler 2019-03-04 17:07:05 UTC
From a RHSM-QE perspective, comment 12 clearly shows that when a RHEL8 consumer registered to Satellite6.4 attempts to set a invalid SLA (due to an innocent typo), there is no feedback given and the value remains set to the former value.  This is indeed a usability regression where the original feedback expected was 'Service level "<INVALID-SLA>" is not available to units of organization <ORG-ID>.'

This change in usability was caused by the new "System Purpose" functionality on RHEL8 which is newly honoured when registered to a Satellite6.5 entitlement server that now permits consumers to set unavailable (including typos) service levels as part of their System Purpose attributes.  Hence we have a small backward (to Satellite6.4) regression in usability.

Note: Going forward on RHEL8 with Satellite6.5, RFE Bug 1632283 will be used to track the usability fix for this issue.

Since this is really a low severity (negative testing) issue against Satellite6.4, my vote would be to defer a fix (if possible - NEEDINFO from dev) to rhel-8.1.0 and add a rhel8.0 known-issue doc for this bug.

Comment 14 Chris Snyder 2019-03-04 17:22:35 UTC
I agree with John in comment 13.

This is something that would be nice to have but not a blocker for 8.0.

Comment 20 Chris Snyder 2019-07-26 17:54:46 UTC
Due to the low severity of this issue and the current phase of the satellite 6.4 (and lower) support lifecycle, we are closing this bug as wontfix.

Satellite 6.4 is currently in Maintenance Support Phase. This means only critical and security related bugs will be fixed.

https://access.redhat.com/support/policy/updates/satellite/

Please note this is only an issue against Satellite 6.4 and lower. It is not an issue against subscription.rhsm.redhat.com/subscription (Customer Portal).


Note You need to log in before you can comment on or make changes to this bug.