Bug 1661423 - 'Change CD' dialog cannot stop loading if connect to guest with ovirt url
Summary: 'Change CD' dialog cannot stop loading if connect to guest with ovirt url
Keywords:
Status: CLOSED DUPLICATE of bug 1717900
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: virt-viewer
Version: 8.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 8.0
Assignee: Virt Viewer Maint
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-21 08:09 UTC by Xiaodai Wang
Modified: 2019-09-24 14:29 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-30 12:21:13 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
virt-viewer debug log (44.87 KB, text/plain)
2018-12-21 08:13 UTC, Xiaodai Wang
no flags Details

Description Xiaodai Wang 2018-12-21 08:09:59 UTC
Description of problem:
'Change CD' dialog cannot stop loading if connect to guest with ovirt url

Version-Release number of selected component (if applicable):
virt-viewer-7.0-3.el8.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Prepare a ISO_DOMAIN in ovirt.
2. Run remote-viewer with ovirt url to connect to a guest.
$ remote-viewer --ovirt-ca-file=ca.crt ovirt://xxxx/xxx 
2. Open 'File->Change CD' dialog.

Actual results:
'Change CD' dialog shows loading status all the time.

Expected results:
'Change CD' dialog should list available ISOs or reports some failure.

Additional info:
The problem cannot be reproduced when connecting with VV file.

Comment 1 Xiaodai Wang 2018-12-21 08:13:39 UTC
Created attachment 1516064 [details]
virt-viewer debug log

Comment 4 Eduardo Lima (Etrunko) 2019-08-30 12:21:13 UTC

*** This bug has been marked as a duplicate of bug 1717900 ***


Note You need to log in before you can comment on or make changes to this bug.