Bug 1661427 - firewalld module is not working due to missing python-firewall package
Summary: firewalld module is not working due to missing python-firewall package
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: ansible
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-21 08:27 UTC by Vaclav Danek
Modified: 2018-12-21 18:29 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-21 18:29:15 UTC


Attachments (Terms of Use)

Description Vaclav Danek 2018-12-21 08:27:34 UTC
Description of problem:
firewalld module is not working due to missing python-firewall package

Version-Release number of selected component (if applicable):
Fedora 28

How reproducible:
Always

Steps to Reproduce:
1. execute task adding firewalld rich rule

Actual results:
TASK [munin-node : firewalld permits munin-node service] **********************************************************************************************************************************************************
fatal: [...]: FAILED! => {"changed": false, "msg": "Python Module not found: firewalld and its python module are required for this module,                         version 0.2.11 or newer required (0.3.9 or newer for offline operations)"}

Expected results:
Rich rule created

Comment 1 Kevin Fenzi 2018-12-21 18:29:15 UTC
In Fedora 28 and later, firewalld has dropped it's python2 bindings and only has python3 ones. Thus you will need to tell ansible to use python3 on that target.

See: https://docs.ansible.com/ansible/latest/reference_appendices/python_3_support.html for details, but you want to set 'ansible_python_interpreter=/usr/bin/python3'

In ansible 2.8 or so they plan to try and autodetect the python version to use on the target(s), in the mean time sorry for the confusion.


Note You need to log in before you can comment on or make changes to this bug.