Bug 1661432 - VMware image created on the Satellite WEB-UI with UUID does not work.
Summary: VMware image created on the Satellite WEB-UI with UUID does not work.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Compute Resources - VMWare
Version: 6.4
Hardware: x86_64
OS: Linux
unspecified
low vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-21 08:50 UTC by Satyajit Das
Modified: 2020-08-31 15:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-31 15:04:42 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Satyajit Das 2018-12-21 08:50:28 UTC
Description of problem:

VMware image created on the Satellite WEB-UI with UUID does not work.

Version-Release number of selected component (if applicable):

Satellite 6.4

Vcenter 6.7


How reproducible:

100%

Steps to Reproduce:
1. Create an image on the Satellite web-ui.
2. Log into the Satellite web-ui --> Infrastructure --> Compute Resource (VMWARE TYPE)--> drill on the vcenter compute resource--> Click on the image tab--> Click on Create Image.
3. Fill all the details with the chosen image and click on submit. The image will be created with the uuid. For example "50134858-ff98-d7f0-58bc-bb52d1c13264"

4. Then tried to provision a host with the image.

Actual results:

Got the below exception:-

Fog::Compute::Vsphere::NotFound: 5005f013-0b7a-c991-aa5f-66fff43e379a was not found


Expected results:

It should have provisioned a new host.

Additional info:

However, if with hammer command we try to replace the UUID with the path on VMware where the images lives, it does work.

hammer compute-resource image create --name "Test-rhel6-am1" \
--operatingsystem "RedHat 7.5" --architecture "x86_64" --username root \
--uuid "Templates/Test-rhel75-am1" \
--compute-resource "Test"

Comment 6 Bryan Kearney 2020-07-06 15:39:17 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 7 Bryan Kearney 2020-08-31 15:04:42 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.