Bug 166149 - Some systems reset trying to launch installer while starting kernel
Some systems reset trying to launch installer while starting kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2005-08-17 10:48 EDT by Erik Jacobson
Modified: 2015-01-04 17:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 17:41:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik Jacobson 2005-08-17 10:48:13 EDT
There was a report in fedora ia64 that RX2600 systems can't launch the
installer.  I confirmed this problem.  Here is my note on this.

PS: I've assigned this to myself.  Please feel free to take it.  Otherwise, my
hope is to spend some time trying to narrow this done a bit as I have time.

Email snip:

For the heck of it, I burned boot.iso from our current ia64 development
mirror.  I'm seeing the same thing with an RX2600 server at the lab
here - death at perfmon.

I was unable to get _any_ kernel messages to the serial console.

On that machine, we had noticed that kernels older than 2.6.10 need
console=ttyS0 while newer kernels need console=ttyS3.  But neither worked
for me.  I in fact tried ttyS0,1,2,3 and 4 and gave up...

I did do an install on to an Altix ia64 system yesterday and that worked
as expected.

Looks like someone needs to dig in to it further to the RX2600 issue.

PS:
They are currently working through some installer issues so it seems
to only be possible to install a minimal system, at least for the
ia64 development stuff at this moment.
Comment 1 Erik Jacobson 2005-08-17 20:17:29 EDT
Not just RX2600....

Date: Wed, 17 Aug 2005 19:15:01 -0500
From: Erik Jacobson <erikj@sgi.com>
To: Erik Jacobson <erikj@sgi.com>
Cc: ia64 Fedora Core Development <fedora-ia64-list@redhat.com>
Subject: Re: [Fedora-ia64-list] Problems with Fedora core 4 on itanium.

Unfortunately, I have to stop for tonight.  I have just a bit more information
on this.  First, I did try a newer version of the boot.iso which should have
the slightly newer kernel the Prarit noted.  I still had the problem.

Then I switched to using a McKinley SDV (tiger) box here.  This machine had
a problem in a similar spot but spit out a tracback on the vga console.

I scribbled it down (just the function names).  I guess I'll start trying to
isolate patches out if nobody has better suggestions.  I'll have to do this
as I have free time though.

Here is my hand written note on this.  I was unable to get anything out the
serial console so I wasn't able to cut and paste.

die
die_if_kernel
ia64_handle_unaligned
ia64_prepare_handle_unaligned
ia64_leave_kernel
gen_pool_free
uncached_build_memmap
efi_memmap_walk_uc
uncached_init
kernel_thread_helper
start_kernel_thread
Comment 2 Erik Jacobson 2005-08-18 13:16:40 EDT
Tony Luck reported that CONFIG_IA64_UNCACHED_ALLOCATOR has a known problem.

Andreas added this:

I have  a working kernel now on the rx2600 :-))
The changes:

- disable "PnP ACPI support" (CONFIG_PNPACPI) for serial console
- disable "Support communication between SGI SSIs"
(CONFIG_IA64_SGI_SN_XP) in order to disable
CONFIG_IA64_UNCACHED_ALLOCATOR, as suggested by Tony  (actually no
serial output if this is still enabled)
- built SCSI and MPT into the kernel so the disks are found !?!?!?


Andreas
Comment 3 Erik Jacobson 2005-08-18 16:17:48 EDT
I'm unassigning this from me.  I think we've got a decent amount of info
now.  We have short-term work arounds here if RedHat is interested.

Date: Thu, 18 Aug 2005 15:15:02 -0500
From: Erik Jacobson <erikj@sgi.com>
To: ia64 Fedora Core Development <fedora-ia64-list@redhat.com>
Subject: Re: [Fedora-ia64-list] Problems with Fedora core 4 on itanium.

Hi.

So I generated a new kernel RPM from the SRPM based on 1487_FC5.

The diff for the config file looks like this:


--- kernel-2.6.12-ia64.config.BAK       2005-08-18 08:37:25.000000000 -0500
+++ kernel-2.6.12-ia64.config   2005-08-18 12:10:22.000000000 -0500
@@ -2613,7 +2613,7 @@
 # CONFIG_IA64_DEBUG_IRQ is not set
 # CONFIG_MTD is not set
 CONFIG_SGI_SNSC=y
-CONFIG_IA64_SGI_SN_XP=m
+# CONFIG_IA64_SGI_SN_XP is not set
 CONFIG_IA64_SGI_SN_SIM=y
 # CONFIG_SCSI_BUSLOGIC is not set
 # CONFIG_CC_OPTIMIZE_FOR_SIZE is not set
@@ -2651,7 +2651,7 @@
 # CONFIG_HOTPLUG_PCI_SHPC_PHPRM_LEGACY is not set
 CONFIG_HOTPLUG_PCI_SGI=m
 CONFIG_ACPI_VIDEO=m
-CONFIG_PNPACPI=y
+# CONFIG_PNPACPI is not set
 # CONFIG_MMC_WBSD is not set
 CONFIG_SCHED_SMT=y
 # CONFIG_SGI_TIOCX is not set

This was the only change I made.

I installed this on an Altix ia64 system first and it still worked there.

I then installed it on the rx2600 that had a version of rhel4 on it.
It blew up, but late in kernel messages.  I believe I was hitting the
same problem you were with the right kernel modules not being in place
to mount root.  At least this confirmed we weren't hitting the same
old issues.

Then I busted open the boot.img file and updated the kernel modules and
kernel itself within (including the modules cpio file within the
initrd).

I used that to boot the installer on the rx2600 on the vga console.  The
installer popped up in graphics mode, the disks were found, and then it
blew up with an anaconda error.  I started the installer again on the vga
screen in 'text' mode.  That install is progressing as we speak.

As you noted, I'm going to have to boot with a different OS, then chroot
in to the fedora development root I just installed and install the updated
kernel there because I didn't "pollute" our fedora development mirror with my
one-off kernel :)

I didn't play with the serial console this time except to do some echo
commands from the installer "shell" virtual to discover the console
was indeed ttyS3.
Comment 4 Dave Jones 2005-08-19 17:41:59 EDT
those changes were made to todays rawhide build. (1500)

Note You need to log in before you can comment on or make changes to this bug.