Bug 1661592 - podman build produces ERRO[0000] HOSTNAME is not supported for OCI image format, hostname 1d561c58fd2b will be ignored. Must use `docker` format
Summary: podman build produces ERRO[0000] HOSTNAME is not supported for OCI image form...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: podman
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Daniel Walsh
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
: 1679987 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-21 17:14 UTC by Jan Pazdziora
Modified: 2019-06-14 02:04 UTC (History)
11 users (show)

Fixed In Version: podman-1.0
Doc Type: If docs needed, set a value
Doc Text:
No documentation required
Clone Of:
Environment:
Last Closed: 2019-06-14 02:04:42 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Pazdziora 2018-12-21 17:14:47 UTC
Description of problem:

When building simple image, I get

ERRO[0000] HOSTNAME is not supported for OCI image format, hostname 1d561c58fd2b will be ignored. Must use `docker` format 

Version-Release number of selected component (if applicable):

podman-0.11.1.1-2.git594495d.module+el8+2237+43d1adf6.x86_64

How reproducible:

Deterministic.

Steps to Reproduce:
1. Have Dockerfile:

FROM registry.access.redhat.com/rhel7
RUN date

2. Run podman build .

Actual results:

STEP 1: FROM registry.access.redhat.com/rhel7
STEP 2: RUN date
ERRO[0000] read container terminal output: input/output error: input/output error 
Fri Dec 21 17:10:14 UTC 2018
ERRO[0000] HOSTNAME is not supported for OCI image format, hostname 1d561c58fd2b will be ignored. Must use `docker` format 
--> 7e86c2a2c1a79c491574548dfff1605080e376e76039053dd1be6307b763d7ff
STEP 3: COMMIT 

Expected results:

STEP 1: FROM registry.access.redhat.com/rhel7
STEP 2: RUN date
Fri Dec 21 17:10:14 UTC 2018
--> 7e86c2a2c1a79c491574548dfff1605080e376e76039053dd1be6307b763d7ff
STEP 3: COMMIT 

Additional info:

Comment 1 Daniel Walsh 2019-01-02 14:07:09 UTC
Needs to be fixed in Buildah first.
https://github.com/containers/buildah/pull/1253

Comment 2 Daniel Walsh 2019-01-10 20:43:58 UTC
Fixed in podman 1.0

Comment 7 Joy Pu 2019-02-15 06:34:51 UTC
Test with podman-1.0.0-2.git921f98f.module+el8+2784+9a0c1dfe.x86_64 and the test steps in comments #1 is passed. So set this to verified. Details:
# podman build -t test .
STEP 1: FROM registry.access.redhat.com/rhel7
STEP 2: RUN date
Fri Feb 15 06:30:38 UTC 2019
--> d6f6847a768bc5a4fc3ab463fc8b84f3f723907c326a785b6101ecec8b3d047e
STEP 3: COMMIT test
--> f7ccf066aa7f97d145577f853dc443c7c18bbbebe25c2a1c06b6b7a57c4c50d5

Comment 8 Chris Negus 2019-04-12 00:49:41 UTC
*** Bug 1679987 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.