Bug 1661622 - failed to retrieve docker-runc version: unknown output format
Summary: failed to retrieve docker-runc version: unknown output format
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker
Version: 7.6
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Frantisek Kluknavsky
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1186913 1636853
TreeView+ depends on / blocked
 
Reported: 2018-12-21 19:04 UTC by Steven Walter
Modified: 2019-03-06 00:46 UTC (History)
7 users (show)

Fixed In Version: docker-1.13.1-89.git07f3374.el7_6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-31 19:20:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0240 None None None 2019-01-31 19:20:57 UTC

Description Steven Walter 2018-12-21 19:04:48 UTC
Description of problem:
Error appearing in docker logs:
Dec 21 12:12:25 ip-xx-xx-xx-xx.example.internal dockerd-current[4198]: time="2018-12-21T12:12:25.221986131Z" level=warning msg="failed to retrieve docker-runc version: unknown output format: runc version spec: 1.0.0-rc2-dev\n"

Version-Release number of selected component (if applicable):
docker-1.13.1-88.git07f3374.el7.x86_64                      Mon Dec 17 18:43:55 2018
docker-client-1.13.1-88.git07f3374.el7.x86_64               Mon Dec 17 18:43:53 2018
docker-common-1.13.1-88.git07f3374.el7.x86_64               Mon Dec 17 18:43:52 2018
docker-rhel-push-plugin-1.13.1-88.git07f3374.el7.x86_64     Mon Dec 17 18:43:52 2018
kernel-3.10.0-862.el7.x86_64

How reproducible:
Unconfirmed

Additional info:
Similar to https://access.redhat.com/solutions/3409151 however it is occurring on a later version than that
This is possibly a regression of: https://bugzilla.redhat.com/show_bug.cgi?id=1485832

Comment 3 Daniel Walsh 2018-12-21 19:27:30 UTC
Is this a packaging issue?

Comment 4 Derrick Ornelas 2019-01-03 17:03:40 UTC
Seems to be an issue with docker-runc-current between 1.13.1-84.git07f3374.el7 and 1.13.1-88.git07f3374.el7


# rpm -q docker docker-common docker-client docker-rhel-push-plugin
docker-1.13.1-84.git07f3374.el7.x86_64
docker-common-1.13.1-84.git07f3374.el7.x86_64
docker-client-1.13.1-84.git07f3374.el7.x86_64
docker-rhel-push-plugin-1.13.1-84.git07f3374.el7.x86_64


# docker info | grep -A5 Runtimes
  WARNING: You're not using the default seccomp profile
Runtimes: docker-runc runc
Default Runtime: docker-runc
Init Binary: /usr/libexec/docker/docker-init-current
containerd version:  (expected: aa8187dbd3b7ad67d8e5e3a15115d3eef43a7ed1)
runc version: 5eda6f6fd0c2884c2c8e78a6e7119e8d0ecedb77 (expected: 9df8b306d01f59d3a8029be411de015b7304dd8f)
init version: fec3683b971d9c3ef73f284f176672c44b448662 (expected: 949e6facb77383876aeff8a6944dde66b3089574)


# journalctl -u docker --since -1d | grep "failed to retrieve docker-runc version" | wc -l
0

# /usr/libexec/docker/docker-runc-current --version
runc version 1.0.0-rc2
commit: 5eda6f6fd0c2884c2c8e78a6e7119e8d0ecedb77
spec: 1.0.0-rc2-dev


# yum update docker
[...]
# rpm -q docker docker-common docker-client docker-rhel-push-plugin
docker-1.13.1-88.git07f3374.el7.x86_64
docker-common-1.13.1-88.git07f3374.el7.x86_64
docker-client-1.13.1-88.git07f3374.el7.x86_64
docker-rhel-push-plugin-1.13.1-88.git07f3374.el7.x86_64


# docker info | grep -A5 Runtimes
  WARNING: You're not using the default seccomp profile
Runtimes: docker-runc runc
Default Runtime: docker-runc
Init Binary: /usr/libexec/docker/docker-init-current
containerd version:  (expected: aa8187dbd3b7ad67d8e5e3a15115d3eef43a7ed1)
runc version: N/A (expected: 9df8b306d01f59d3a8029be411de015b7304dd8f)
init version: fec3683b971d9c3ef73f284f176672c44b448662 (expected: 949e6facb77383876aeff8a6944dde66b3089574)


# journalctl -u docker --since -1d | grep "failed to retrieve docker-runc version" | wc -l
2

# /usr/libexec/docker/docker-runc-current --version
runc version spec: 1.0.0-rc2-dev

Comment 6 Antonio Murdaca 2019-01-08 13:39:26 UTC
Looks like a packaging issue to me, we fixed this already long ago but we may have regressed. Lokesh can you take a look as to why we're not building with commit info (.git directory probably) anymore?

Comment 12 errata-xmlrpc 2019-01-31 19:20:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0240


Note You need to log in before you can comment on or make changes to this bug.