Bug 166165 - mount -t ntfs ... throws "unknown filesystem" error
Summary: mount -t ntfs ... throws "unknown filesystem" error
Status: CLOSED DUPLICATE of bug 65749
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-17 18:32 UTC by Tom Berger
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-17 18:47:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom Berger 2005-08-17 18:32:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
In trying to mount a firewire external hard drive, the following error is produced:

# mount -t ntfs /dev/sdb1 /media/ieee1394disk
mount: unknown filesystem type 'ntfs'

Fdisk output is as follows:
# fdisk -l /dev/sdb
Disk /dev/sdb: 300.0 GB, 300000739328 bytes
255 heads, 63 sectors/track, 36473 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1       36472   292961308+   7  HPFS/NTFS

The mount manpage lists ntfs as a supported filesystem (as does the FC4 "Unleashed" book), so this seems like a bug and not a removed feature.


Version-Release number of selected component (if applicable):
2.6.12-1.1398_FC4

How reproducible:
Always

Steps to Reproduce:
1. Connect the firewire drive to the computer (Dell Dimension 8400)
2. Turn it on
3. As root, type "mount -t ntfs /dev/sdb1 /media/ieee1394disk
  

Actual Results:  Error message:

mount: unknown filesystem type 'ntfs'

Expected Results:  The drive should have mounted to the mount_point /media/iee1394disk

Additional info:

1. Can't mount it as ext3: mount reports that the filesystem is incorrect for the drive. 

2. Can't mount it as "hpfs", or "NTFS" or "HPFS/NTFS": same "unknown filesystem" error. 

3. mount -t auto gives same error.

4. /etc/filesystems looks like this:
ext3
ext2
nodev proc
nodev devpts
iso9660
vfat
hfs

Comment 1 Dave Jones 2005-08-17 18:47:20 UTC


*** This bug has been marked as a duplicate of 65749 ***


Note You need to log in before you can comment on or make changes to this bug.