Bug 1661680 - Realtek Driver Bug
Summary: Realtek Driver Bug
Keywords:
Status: CLOSED DUPLICATE of bug 1650984
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-22 02:17 UTC by fleabeard
Modified: 2018-12-24 12:03 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-24 12:03:29 UTC


Attachments (Terms of Use)

Description fleabeard 2018-12-22 02:17:02 UTC
Description of problem:
After installing Fedora 29 and rebooting, my Realtek Ethernet doesn't work and is bridged by virbr0 with no working internet/networking connections.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Install Fedora 29
2. Reboot Computer
3. Wired Ethernet doesn't work. Status of Wired Connection in Network Manager is (unplugged)

Actual results:
Wired Ethernet stops working and is bridged by virbr0. No internet access is available in either. No VM's are used in this bug.

Expected results:
Working wired ethernet.

Additional info:
Using a Realtek onboard NIC
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 03)

The fix is to reload the driver via 'sudo rmmod r8169' & 'modprobe r8169' then everything works as it should.

Comment 1 fleabeard 2018-12-22 02:20:01 UTC
Forgot to mention kernel version:
Linux localhost.localdomain 4.19.9-300.fc29.x86_64 #1 SMP Thu Dec 13 17:25:01 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Comment 2 Hans de Goede 2018-12-24 12:03:29 UTC
This is a duplicate of bug 1650984, people have been debugging this issue in that bug and hopefully a fix will be available soon (but it is a hard to pin down issue). Please add any further comments you may have to bug 1650984.

*** This bug has been marked as a duplicate of bug 1650984 ***


Note You need to log in before you can comment on or make changes to this bug.