Bug 1661774 - [Downstream CI] Fix dependency on requests library version
Summary: [Downstream CI] Fix dependency on requests library version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-octavia-tests-tempest
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: z4
: 13.0 (Queens)
Assignee: Nir Magnezi
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-23 09:05 UTC by Nir Magnezi
Modified: 2019-01-16 17:54 UTC (History)
2 users (show)

Fixed In Version: python-octavia-tests-tempest-0.2.0-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-16 17:54:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack Storyboard 2004641 0 None None None 2018-12-23 09:05:53 UTC
OpenStack gerrit 625836 0 None master: MERGED octavia-tempest-plugin: Fix dependency on requests library version (I15b496c740b0c7c8970501d08497ba43cbffda2b) 2019-01-03 16:42:07 UTC
Red Hat Product Errata RHBA-2019:0088 0 None None None 2019-01-16 17:54:13 UTC

Description Nir Magnezi 2018-12-23 09:05:53 UTC
Description of problem:
=======================

The test test_l7policies_and_l7rules[1] fails in our downstream CI[2](Red Hat internal URL).
The root cause of this issue, as described in the upstream fix, is due to the version of python-requests that we ship in OSP13.

Instead of bumping the python-requests version (impacts packaging for an already released OSP version), we can work around the issue in octavia-tempepest-plugin.


Currently the result is:

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/octavia_tempest_plugin/tests/scenario/v2/test_traffic_ops.py", line 617, in test_l7policies_and_l7rules
    redirect=True)
  File "/usr/lib/python2.7/site-packages/octavia_tempest_plugin/tests/test_base.py", line 791, in assertConsistentResponse
    self.assertEqual(response_content, req.next.url)
AttributeError: 'Response' object has no attribute 'next

[1]  octavia_tempest_plugin.tests.scenario.v2.test_traffic_ops.TrafficOperationsScenarioTest.test_l7policies_and_l7rules

Comment 15 errata-xmlrpc 2019-01-16 17:54:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0088


Note You need to log in before you can comment on or make changes to this bug.