Bug 16618 - problem with ksh
problem with ksh
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: pdksh (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-20 04:17 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-20 04:17:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-08-20 04:17:44 EDT
Hi,
Thanks fro your answer, but i 've still a problem !!!

it-s whith ksh (the problem is ok with zsh, but zsh have problem with 
arrays (i've programs to prove it !)

The value next the loop is the same than before the loop, and not the 
value at the end of the loop !!!

Try this  short program, it count normally the number of file in a 
directory (ls |wc -l equivalent), I use this structure in multiple shells 
to administrate Oracle databases, and i'm very embarassed !!!

thanks to help me (sorry for my poor english)

gbouchez@nordnet.fr

#!/bin/ksh
a=0
echo $a
ls  | while read FILE
do
   let a=a+1
   echo $a
done
echo 'end of loop'
echo $a

Thanks...
Comment 1 Trond Eivind Glomsrxd 2000-08-20 10:35:10 EDT
You are piping it into something which can the be a separate process... user
error.
Comment 2 Need Real Name 2000-08-20 13:25:40 EDT
Hi,
i'm not ok with your answer, because, when i work on sun Solaris or HP-UX
this command is OK !

So for me , there's a problem with linux...

Comment 3 Trond Eivind Glomsrxd 2000-08-20 13:33:42 EDT
That something works that way in some places, does not mean that everything
needs to work that way... e.g, take a look at #8894 (which also concerns the
read facility, BTW). If you disagree, I suggest you contact the author
(http://www.cs.mun.ca/~michael/pdksh/)

Note You need to log in before you can comment on or make changes to this bug.