Bug 1661823 - Snapshot creation for a VM with disks on iSCSI domain fails with NullPointerException in case an NFS domain in the DC becomes unreachable
Summary: Snapshot creation for a VM with disks on iSCSI domain fails with NullPointerE...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.3.0
Hardware: x86_64
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-4.3.2
: 4.3.2.1
Assignee: Ahmad Khiet
QA Contact: Yosi Ben Shimon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-23 16:31 UTC by Elad
Modified: 2019-05-30 14:51 UTC (History)
4 users (show)

Fixed In Version: ovirt-engine-4.3.2.1
Doc Type: Removed functionality
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-26 07:20:47 UTC
oVirt Team: Storage
rule-engine: ovirt-4.3+


Attachments (Terms of Use)
logs and REST calls log (art_test_runner.log.debug.1) (5.25 MB, application/gzip)
2018-12-23 16:31 UTC, Elad
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 97965 master MERGED engine: sorting on null available disk size 2019-03-06 08:48:30 UTC

Description Elad 2018-12-23 16:31:17 UTC
Created attachment 1516388 [details]
logs and REST calls log (art_test_runner.log.debug.1)

Description of problem:
Snapshot creation failed with NPE for a VM with disks reside on iSCSI in case NFS domains in the DC are unreachable.


Version-Release number of selected component (if applicable):
ovirt-engine-4.3.0-0.6.alpha2.el7.noarch
vdsm-4.30.4-1.el7ev.x86_64

How reproducible:
Not sure at the moment, happened following an issue with the NFS storage server during an automation snapshots related tests execution.


Steps to Reproduce:
Have iSCSI and NFS domains in the DC
1. Create a VM from a template as thin clone, resides on iSCSI
2. Attach 4 disks to the VM, all on iSCSI
3. Block connection to the NFS storage of the NFS domains 
4. Create a snapshot for the VM (not live in our case, not sure if it's relevant)


2018-12-23 16:41:54,433 - MainThread - snapshots - DEBUG - CREATE request content is --  url:/ovirt-engine/api/vms/c7ae24b2-9b5f-416e-b30f-ecd2ffd50cac/snapshots body:<snapshot>
    <description>snapshot_None_iscsi_0</description>
</snapshot>


Actual results:


2018-12-23 16:41:54,691+02 INFO  [org.ovirt.engine.core.bll.snapshots.CreateSnapshotForVmCommand] (default task-27) [snapshots_create_b0f43250-7489-491c] Lock Acquired to object 'EngineLock:{exclusiveLocks='[c7a
e24b2-9b5f-416e-b30f-ecd2ffd50cac=VM]', sharedLocks=''}'
2018-12-23 16:41:54,903+02 ERROR [org.ovirt.engine.core.bll.snapshots.CreateSnapshotForVmCommand] (default task-27) [snapshots_create_b0f43250-7489-491c] Error during ValidateFailure.: java.lang.NullPointerExcep
tion
        at java.util.Comparator.lambda$comparing$77a9974f$1(Comparator.java:469) [rt.jar:1.8.0_191]
        at java.util.Collections$ReverseComparator2.compare(Collections.java:5178) [rt.jar:1.8.0_191]
        at java.util.Comparator.lambda$thenComparing$36697e65$1(Comparator.java:217) [rt.jar:1.8.0_191]
        at java.util.TimSort.binarySort(TimSort.java:296) [rt.jar:1.8.0_191]
        at java.util.TimSort.sort(TimSort.java:221) [rt.jar:1.8.0_191]
        at java.util.Arrays.sort(Arrays.java:1512) [rt.jar:1.8.0_191]
        at java.util.ArrayList.sort(ArrayList.java:1462) [rt.jar:1.8.0_191]
        at org.ovirt.engine.core.bll.memory.MemoryStorageHandler.sortStorageDomains(MemoryStorageHandler.java:109) [bll.jar:]
        at org.ovirt.engine.core.bll.memory.MemoryStorageHandler.findStorageDomainForMemory(MemoryStorageHandler.java:82) [bll.jar:]
        at org.ovirt.engine.core.bll.memory.MemoryStorageHandler.findStorageDomainForMemory(MemoryStorageHandler.java:55) [bll.jar:]
        at org.ovirt.engine.core.bll.snapshots.CreateSnapshotForVmCommand.getStorageDomainIdForVmMemory(CreateSnapshotForVmCommand.java:197) [bll.jar:]





Expected results:
Snapshot creation should succeed

Additional info:
logs and REST calls log (art_test_runner.log.debug.1)

Comment 1 Sandro Bonazzola 2019-01-28 09:34:28 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 2 Yosi Ben Shimon 2019-03-21 06:14:51 UTC
Version used for verification:
ovirt-engine-4.3.2.1-0.1.el7.noarch

Tested both cold and live according to steps in the description (manually).
Also executed the automation test case (TestCase18912) a few times while blocking the connection to the NFS storage at the point described in the steps to reproduce.

All worked fine.

Moving to VERIFIED

Comment 3 Sandro Bonazzola 2019-03-26 07:20:47 UTC
This bugzilla is included in oVirt 4.3.2 release, published on March 19th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.2 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.