Bug 1661897 - [machines] The Used and Capacity columns of a newly added disk to a shut off VM can't be shown right after the disk is added
Summary: [machines] The Used and Capacity columns of a newly added disk to a shut off ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: cockpit-appstream
Version: 8.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 8.1
Assignee: Katerina Koukiou
QA Contact: YunmingYang
URL:
Whiteboard:
Depends On: 1678935
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-24 10:05 UTC by Qin Yuan
Modified: 2020-11-14 11:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 20:41:35 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3325 None None None 2019-11-05 20:41:46 UTC

Description Qin Yuan 2018-12-24 10:05:36 UTC
Description of problem:
When a VM is shut off, create a new disk, not using existing ones, the Used and Capacity columns of the newly created disk can't be shown until the Add Disk button is clicked again.

Version-Release number of selected component (if applicable):
cockpit-machines-184-1.el8.noarch
libvirt-dbus-1.2.0-1.module+el8+2529+a9686a4d.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Prepare a VM, and turn it into shut off status
2. Click "Add Disk" button on its Disks subtab
3. Select "Create New" option on the Add Disk dialogue window, and complete other fields, then click Add.
4. Wait for the Used and Capacity columns of the newly created disk to appear
5. Click "Add Disk" button again

Actual results:
1. After step4, the Used and Capacity columns of the newly created disk don't appear.
2. After step5, the Used and Capacity columns of the newly created disk appear immediately.

Expected results:
1. The Used and Capacity columns of the newly created disk could be shown right after the disk is created, not related to "Add Disk" button.

Additional info:

Comment 3 YunmingYang 2019-05-30 04:55:41 UTC
Test Versions:
cockpit-machines-193-1.el8.noarch
libvirt-dbus-1.2.0-2.module+el8.1.0+2983+b2ae9c0a.x86_64


Test Steps:
1. Prepare a VM, and turn it into shut off status
2. Click "Add Disk" button
3. Select "Create New" option on the Add Disk dialogue window, and complete other fields, then click Add.
4. Wait for the Used and Capacity columns of the newly created disk to appear


Test Results:
The Used and Capacity columns of a newly added disk to a shut off VM can be shown in a while after step 4.



According to the results, The Used and Capacity columns of a newly added disk to a shut off VM can be shown in a while without clicking 'Add Disk' button.So move the status to VERIFIED.

Comment 5 errata-xmlrpc 2019-11-05 20:41:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3325


Note You need to log in before you can comment on or make changes to this bug.