Bug 1661974 - Standalone pod is not shown on project Status page
Summary: Standalone pod is not shown on project Status page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-25 05:36 UTC by Yadan Pei
Modified: 2019-06-04 10:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:33 UTC

Description Yadan Pei 2018-12-25 05:36:57 UTC
Description of problem:
Standalone pod is not shown on project Status page

Version-Release number of selected component (if applicable):
quay.io/openshift-release-dev/ocp-v4.0@sha256           068ba37b8219cd2b161078bd3444cd32f79f28bd4a7108847f3e3923f979bc47   7f8e4a1588a2   3 days ago      268 MB
openshift/console commit: c7f598d85ba30c2a8347885d66e44d2c8be448f5

How reproducible:
Always

Steps to Reproduce:
1. Create standalone Pod
$ oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/pods/pod_with_two_containers.json -n test
2. Go to project Status page


Actual results:
2. Pod is not shown on Status page, we can see project get started message since  project is considered as empty

Expected results:
2. Pod should be shown

Additional info:

Comment 1 Samuel Padgett 2019-01-07 16:56:39 UTC
This is currently working as intended, but assigning Jon to evaluate how hard it is to change. We'd only want to show pods that are not terminated most likely.

Comment 2 Jon Jackson 2019-01-09 19:57:52 UTC
https://github.com/openshift/console/pull/1043

Comment 3 Yadan Pei 2019-01-14 07:17:33 UTC
Fix is not included in latest nightly payload registry.svc.ci.openshift.org/ocp/release:4.0.0-0.nightly-2019-01-12-000105, will check in new one

Comment 4 Yadan Pei 2019-01-15 05:35:46 UTC
1. Create standalone pod
2. Go to Home -> Status page, now standalone pod is shown on Status page

Verified on

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.nightly-2019-01-15-010905   True        False         44m       Cluster version is 4.0.0-0.nightly-2019-01-15-010905

$ sudo podman inspect 4043d65804a8
...
            "Labels": {
                "io.openshift.source-repo-commit": "a62eaa43f2aab9a817a3fb66e1c8b88d5ef100da",
                "io.openshift.source-repo-url": "https://github.com/openshift/console",
                "io.openshift.tags": "openshift,console",
                "maintainer": "Samuel Padgett <spadgett@redhat.com>",
                "name": "openshift/ose-console",
                "release": "0.139.0.0",
                "summary": "Provides the latest release of Red Hat Enterprise Linux 7 in a fully featured and supported base image.",
                "url": "https://access.redhat.com/containers/#/registry.access.redhat.com/openshift/ose-console/images/v4.0.0-0.139.0.0",
                "vcs-ref": "f871de84d993327ecc723846bbac3959a36103c1",
                "vcs-type": "git",
                "vendor": "Red Hat, Inc.",
                "version": "v4.0.0"
....

Comment 7 errata-xmlrpc 2019-06-04 10:41:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.